aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gst1-plugins-base
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-03-17 18:54:50 -0700
committerRosen Penev <rosenp@gmail.com>2019-03-17 20:22:06 -0700
commita327cfca219cc8921bab1cfc8af9adae74c42402 (patch)
tree384d5f995973cd6f83342facea362df1d5fa3e70 /multimedia/gst1-plugins-base
parentef12a4c5887c0f71c82d514cb03a76b0418d87d5 (diff)
gst1-plugins-base: Disable various debug checks
Saves on compiled size. Also got rid of outdated rpath linking. Added PIC compilation as is done elsewhere. Added PKG_BUILD_PARALLEL for faster compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia/gst1-plugins-base')
-rw-r--r--multimedia/gst1-plugins-base/Makefile20
-rw-r--r--multimedia/gst1-plugins-base/patches/002-no-tests.patch64
-rw-r--r--multimedia/gst1-plugins-base/patches/003-no-docs.patch29
3 files changed, 11 insertions, 102 deletions
diff --git a/multimedia/gst1-plugins-base/Makefile b/multimedia/gst1-plugins-base/Makefile
index 5335489b7..d38cbedaf 100644
--- a/multimedia/gst1-plugins-base/Makefile
+++ b/multimedia/gst1-plugins-base/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-plugins-base
PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
Ted Hess <thess@kitschensync.net>
@@ -40,6 +40,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_libgst1app \
PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@@ -117,6 +118,15 @@ GST_VERSION:=1.0
CONFIGURE_ARGS += \
--disable-debug \
--disable-examples \
+ --disable-fatal-warnings \
+ --disable-glib-asserts \
+ --disable-gobject-cast-checks \
+ --disable-gtk-doc-html \
+ --disable-introspection \
+ --disable-rpath \
+ --disable-valgrind \
+ --without-html-dir \
+ --with-pic \
\
$(call GST_COND_SELECT,alsa) \
$(call GST_COND_SELECT,app) \
@@ -125,7 +135,6 @@ CONFIGURE_ARGS += \
$(call GST_COND_SELECT,audioresample) \
$(call GST_COND_SELECT,audiotestsrc) \
--disable-cdparanoia \
- --disable-freetypetest \
$(call GST_COND_SELECT,gio) \
--disable-libvisual \
$(call GST_COND_SELECT,ogg) \
@@ -145,16 +154,9 @@ CONFIGURE_ARGS += \
\
--without-libiconv-prefix \
--without-libintl-prefix \
- --without-x \
\
--with-audioresample-format=int \
-TARGET_CFLAGS += -Wno-format-nonliteral
-
-EXTRA_LDFLAGS+= \
- -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
- $(if $(ICONV_FULL),-liconv) \
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/gstreamer-$(GST_VERSION)
( cd $(PKG_INSTALL_DIR); $(CP) \
diff --git a/multimedia/gst1-plugins-base/patches/002-no-tests.patch b/multimedia/gst1-plugins-base/patches/002-no-tests.patch
deleted file mode 100644
index a0e81f819..000000000
--- a/multimedia/gst1-plugins-base/patches/002-no-tests.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff -u --recursive gst-plugins-base-1.15.2-vanilla/configure.ac gst-plugins-base-1.15.2/configure.ac
---- gst-plugins-base-1.15.2-vanilla/configure.ac 2019-03-16 13:40:28.843441622 -0400
-+++ gst-plugins-base-1.15.2/configure.ac 2019-03-16 13:41:14.880578949 -0400
-@@ -1005,41 +1005,6 @@
- pkgconfig/gstreamer-gl-uninstalled.pc
- pkgconfig/gstreamer-plugins-base.pc
- pkgconfig/gstreamer-plugins-base-uninstalled.pc
--tests/Makefile
--tests/check/Makefile
--tests/examples/Makefile
--tests/examples/app/Makefile
--tests/examples/audio/Makefile
--tests/examples/compositor/Makefile
--tests/examples/decodebin_next/Makefile
--tests/examples/dynamic/Makefile
--tests/examples/encoding/Makefile
--tests/examples/fft/Makefile
--tests/examples/gio/Makefile
--tests/examples/gl/Makefile
--tests/examples/gl/generic/Makefile
--tests/examples/gl/generic/cube/Makefile
--tests/examples/gl/generic/doublecube/Makefile
--tests/examples/gl/generic/recordgraphic/Makefile
--tests/examples/gl/generic/cubeyuv/Makefile
--tests/examples/gl/qt/Makefile
--tests/examples/gl/gtk/Makefile
--tests/examples/gl/gtk/fxtest/Makefile
--tests/examples/gl/gtk/3dvideo/Makefile
--tests/examples/gl/gtk/switchvideooverlay/Makefile
--tests/examples/gl/gtk/filternovideooverlay/Makefile
--tests/examples/gl/gtk/filtervideooverlay/Makefile
--tests/examples/gl/cocoa/Makefile
--tests/examples/gl/sdl/Makefile
--tests/examples/overlay/Makefile
--tests/examples/overlaycomposition/Makefile
--tests/examples/seek/Makefile
--tests/examples/snapshot/Makefile
--tests/examples/playback/Makefile
--tests/examples/playrec/Makefile
--tests/files/Makefile
--tests/icles/Makefile
--tests/icles/playback/Makefile
- docs/Makefile
- docs/libs/Makefile
- docs/plugins/Makefile
-diff -u --recursive gst-plugins-base-1.15.2-vanilla/Makefile.am gst-plugins-base-1.15.2/Makefile.am
---- gst-plugins-base-1.15.2-vanilla/Makefile.am 2019-03-16 13:40:28.864441684 -0400
-+++ gst-plugins-base-1.15.2/Makefile.am 2019-03-16 13:41:27.970617996 -0400
-@@ -11,7 +11,6 @@
- gst-libs \
- gst sys $(SUBDIRS_EXT) \
- tools \
-- tests \
- docs \
- common \
- m4
-@@ -22,7 +21,6 @@
- gst-libs \
- gst sys ext \
- tools \
-- tests \
- common \
- m4
-
diff --git a/multimedia/gst1-plugins-base/patches/003-no-docs.patch b/multimedia/gst1-plugins-base/patches/003-no-docs.patch
deleted file mode 100644
index 8746358b8..000000000
--- a/multimedia/gst1-plugins-base/patches/003-no-docs.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -11,13 +11,11 @@ SUBDIRS = \
- gst-libs \
- gst sys $(SUBDIRS_EXT) \
- tools \
-- docs \
- common \
- m4
-
- DIST_SUBDIRS = \
- pkgconfig \
-- docs \
- gst-libs \
- gst sys ext \
- tools \
---- a/configure.ac
-+++ b/configure.ac
-@@ -992,10 +992,6 @@ pkgconfig/gstreamer-gl.pc
- pkgconfig/gstreamer-gl-uninstalled.pc
- pkgconfig/gstreamer-plugins-base.pc
- pkgconfig/gstreamer-plugins-base-uninstalled.pc
--docs/Makefile
--docs/libs/Makefile
--docs/plugins/Makefile
--docs/version.entities
- common/Makefile
- common/m4/Makefile
- m4/Makefile