aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gst1-plugins-bad
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2019-03-16 19:35:49 -0400
committerW. Michael Petullo <mike@flyn.org>2019-03-16 19:35:49 -0400
commitfc6a8039a1b8a516be5d896878bfac253b4f08e3 (patch)
tree763ce04f1e69a487ff6f65930b837acd264fae28 /multimedia/gst1-plugins-bad
parentc16cbe772594f3c9352093ddca7fdaac15ad2015 (diff)
gst1-plugins-bad: update to 1.15.2
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'multimedia/gst1-plugins-bad')
-rw-r--r--multimedia/gst1-plugins-bad/Makefile4
-rw-r--r--multimedia/gst1-plugins-bad/patches/002-no-tests.patch41
-rw-r--r--multimedia/gst1-plugins-bad/patches/003-openssl-deprecated.patch53
3 files changed, 23 insertions, 75 deletions
diff --git a/multimedia/gst1-plugins-bad/Makefile b/multimedia/gst1-plugins-bad/Makefile
index 752ee51f0..fcc3e1561 100644
--- a/multimedia/gst1-plugins-bad/Makefile
+++ b/multimedia/gst1-plugins-bad/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-plugins-bad
-PKG_VERSION:=1.14.4
+PKG_VERSION:=1.15.2
PKG_RELEASE:=1
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@@ -20,7 +20,7 @@ PKG_LICENSE_FILES:=COPYING.LIB COPYING
PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-bad-$(PKG_VERSION)
PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
-PKG_HASH:=910b4e0e2e897e8b6d06767af1779d70057c309f67292f485ff988d087aa0de5
+PKG_HASH:=eafbb705190ca6dbf0e5dfbe1bc3d0f217fbc2a828037b5ede12d3611b9f9bd7
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
diff --git a/multimedia/gst1-plugins-bad/patches/002-no-tests.patch b/multimedia/gst1-plugins-bad/patches/002-no-tests.patch
index 38c57039c..f5ee28ee2 100644
--- a/multimedia/gst1-plugins-bad/patches/002-no-tests.patch
+++ b/multimedia/gst1-plugins-bad/patches/002-no-tests.patch
@@ -1,22 +1,7 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -2,11 +2,11 @@ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
-
- SUBDIRS = \
- gst-libs gst sys ext pkgconfig \
-- m4 common docs tests tools
-+ m4 common docs tools
-
- DIST_SUBDIRS = \
- gst gst-libs sys ext pkgconfig \
-- m4 common docs tests tools
-+ m4 common docs tools
-
- EXTRA_DIST = \
- depcomp \
---- a/configure.ac
-+++ b/configure.ac
-@@ -2600,24 +2600,6 @@ sys/vdpau/Makefile
+diff -u --recursive gst-plugins-bad-1.15.2-vanilla/configure.ac gst-plugins-bad-1.15.2/configure.ac
+--- gst-plugins-bad-1.15.2-vanilla/configure.ac 2019-03-16 19:01:31.866656521 -0400
++++ gst-plugins-bad-1.15.2/configure.ac 2019-03-16 19:02:41.864809432 -0400
+@@ -2609,23 +2609,6 @@
sys/wasapi/Makefile
sys/winks/Makefile
sys/winscreencap/Makefile
@@ -27,7 +12,6 @@
-tests/examples/avsamplesink/Makefile
-tests/examples/camerabin2/Makefile
-tests/examples/codecparsers/Makefile
--tests/examples/compositor/Makefile
-tests/examples/directfb/Makefile
-tests/examples/audiomixmatrix/Makefile
-tests/examples/ipcpipeline/Makefile
@@ -41,3 +25,20 @@
ext/voamrwbenc/Makefile
ext/voaacenc/Makefile
ext/assrender/Makefile
+diff -u --recursive gst-plugins-bad-1.15.2-vanilla/Makefile.am gst-plugins-bad-1.15.2/Makefile.am
+--- gst-plugins-bad-1.15.2-vanilla/Makefile.am 2019-03-16 19:01:31.865656518 -0400
++++ gst-plugins-bad-1.15.2/Makefile.am 2019-03-16 19:02:34.694793766 -0400
+@@ -2,11 +2,11 @@
+
+ SUBDIRS = \
+ gst-libs gst sys ext pkgconfig \
+- m4 common docs tests tools
++ m4 common docs tools
+
+ DIST_SUBDIRS = \
+ gst gst-libs sys ext pkgconfig \
+- m4 common docs tests tools
++ m4 common docs tools
+
+ EXTRA_DIST = \
+ depcomp \
diff --git a/multimedia/gst1-plugins-bad/patches/003-openssl-deprecated.patch b/multimedia/gst1-plugins-bad/patches/003-openssl-deprecated.patch
deleted file mode 100644
index 1df1f73a9..000000000
--- a/multimedia/gst1-plugins-bad/patches/003-openssl-deprecated.patch
+++ /dev/null
@@ -1,53 +0,0 @@
---- a/ext/dtls/gstdtlsagent.c
-+++ b/ext/dtls/gstdtlsagent.c
-@@ -124,11 +124,11 @@ _gst_dtls_init_openssl (void)
- }
-
- GST_INFO_OBJECT (NULL, "initializing openssl %lx", OPENSSL_VERSION_NUMBER);
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- SSL_library_init ();
- SSL_load_error_strings ();
- ERR_load_BIO_strings ();
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
- {
- gint i;
- gint num_locks;
-@@ -197,7 +197,7 @@ gst_dtls_agent_init (GstDtlsAgent * self)
- SSL_CTX_set_cipher_list (priv->ssl_context,
- "ALL:!ADH:!LOW:!EXP:!MD5:@STRENGTH");
- SSL_CTX_set_read_ahead (priv->ssl_context, 1);
--#if OPENSSL_VERSION_NUMBER >= 0x1000200fL
-+#if (OPENSSL_VERSION_NUMBER >= 0x1000200fL) && (OPENSSL_VERSION_NUMBER < 0x10100000L)
- SSL_CTX_set_ecdh_auto (priv->ssl_context, 1);
- #endif
- }
---- a/ext/dtls/gstdtlscertificate.c
-+++ b/ext/dtls/gstdtlscertificate.c
-@@ -45,8 +45,15 @@
- #endif
- #endif
-
-+#include <openssl/bn.h>
-+#include <openssl/rsa.h>
- #include <openssl/ssl.h>
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#define X509_getm_notBefore X509_get_notBefore
-+#define X509_getm_notAfter X509_get_notAfter
-+#endif
-+
- GST_DEBUG_CATEGORY_STATIC (gst_dtls_certificate_debug);
- #define GST_CAT_DEFAULT gst_dtls_certificate_debug
-
-@@ -240,8 +247,8 @@ init_generated (GstDtlsCertificate * self)
-
- X509_set_version (priv->x509, 2);
- ASN1_INTEGER_set (X509_get_serialNumber (priv->x509), 0);
-- X509_gmtime_adj (X509_get_notBefore (priv->x509), 0);
-- X509_gmtime_adj (X509_get_notAfter (priv->x509), 31536000L); /* A year */
-+ X509_gmtime_adj (X509_getm_notBefore (priv->x509), 0);
-+ X509_gmtime_adj (X509_getm_notAfter (priv->x509), 31536000L); /* A year */
- X509_set_pubkey (priv->x509, priv->private_key);
-
- name = X509_get_subject_name (priv->x509);