aboutsummaryrefslogtreecommitdiff
path: root/multimedia/gst1-libav/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-03-17 18:41:34 -0700
committerRosen Penev <rosenp@gmail.com>2019-03-17 20:22:06 -0700
commitef12a4c5887c0f71c82d514cb03a76b0418d87d5 (patch)
tree16490f1a24e4f64a8e080968682f7460ab4d889e /multimedia/gst1-libav/Makefile
parenta5a0a350817f4398ef9c6094e1d6e11af478c219 (diff)
gst1-libav: Remove debug and other random stuff
Should lower filesize. I can't tell by how much as this was not building on mvebu before. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'multimedia/gst1-libav/Makefile')
-rw-r--r--multimedia/gst1-libav/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/multimedia/gst1-libav/Makefile b/multimedia/gst1-libav/Makefile
index 79fb247fe..b10d050ec 100644
--- a/multimedia/gst1-libav/Makefile
+++ b/multimedia/gst1-libav/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gst1-libav
PKG_VERSION:=1.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
Ted Hess <thess@kitschensync.net>
@@ -146,12 +146,27 @@ LIBAV_CONFIGURE_PROTOCOLS:=$(call FILTER_CONFIG,PROTOCOL,protocol,$(LIBAV_PROTOC
REAL_CPU_TYPE:=$(firstword $(subst +, ,$(CONFIG_CPU_TYPE)))
CONFIGURE_ARGS += \
+ --disable-Bsymbolic \
+ --disable-fatal-warnings \
+ --disable-glib-asserts \
+ --disable-gobject-cast-checks \
+ --disable-gtk-doc-html \
+ --disable-valgrind \
--without-system-libav \
+ --with-pic \
--with-libav-extra-configure=" \
$(if $(REAL_CPU_TYPE),--cpu=$(call qstrip,$(REAL_CPU_TYPE)),) \
--disable-bsfs \
--disable-programs \
--disable-devices \
+ --disable-debug \
+ --disable-doc \
+ --disable-extra-warnings \
+ --disable-htmlpages \
+ --disable-manpages \
+ --disable-podpages \
+ --disable-txtpages \
+ --disable-runtime-cpudetect \
--disable-encoders \
$(LIBAV_CONFIGURE_ENCODERS) \
--disable-decoders \
@@ -182,11 +197,7 @@ CONFIGURE_ARGS += \
--disable-fma4 \
--disable-avx2 \
--disable-inline-asm \
- --disable-yasm"
-
-TARGET_CFLAGS += -D_GNU_SOURCE -Wno-format-nonliteral
-
-TARGET_LDFLAGS += $(FPIC)
+ --disable-x86asm"
define Package/gst1-libav/install
$(INSTALL_DIR) $(1)/usr/lib/gstreamer-$(GST_VERSION)