aboutsummaryrefslogtreecommitdiff
path: root/multimedia/grilo-plugins
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2020-01-20 10:57:15 -0500
committerW. Michael Petullo <mike@flyn.org>2020-01-20 11:39:28 -0500
commitb03602c26fb447dc0c671440de4abdfc913aca8f (patch)
tree4355d5d8e1f35e27e7e1bc9fc4b0d02233e00fc0 /multimedia/grilo-plugins
parent1437cbb5e844c904618b05f476dbf2afe8940204 (diff)
grilo-plugins: update to 0.3.10 and build with meson
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'multimedia/grilo-plugins')
-rw-r--r--multimedia/grilo-plugins/Makefile48
-rw-r--r--multimedia/grilo-plugins/patches/001-no-help-po-tests.patch15
-rw-r--r--multimedia/grilo-plugins/patches/001-remove-docs-gnome-from-configure.ac.patch31
-rw-r--r--multimedia/grilo-plugins/src/m4/gnome-common.m432
-rw-r--r--multimedia/grilo-plugins/src/m4/gnome-compiler-flags.m4184
5 files changed, 37 insertions, 273 deletions
diff --git a/multimedia/grilo-plugins/Makefile b/multimedia/grilo-plugins/Makefile
index 632fe4de4..b976b42c9 100644
--- a/multimedia/grilo-plugins/Makefile
+++ b/multimedia/grilo-plugins/Makefile
@@ -6,8 +6,8 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=grilo-plugins
-PKG_VERSION:=0.3.7
-PKG_RELEASE:=3
+PKG_VERSION:=0.3.10
+PKG_RELEASE:=1
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
PKG_LICENSE:=LGPLv2.1
@@ -15,14 +15,15 @@ PKG_LICENSE_FILES:=COPYING
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/grilo-plugins/0.3/
-PKG_HASH:=fc2f3bbc319136e53e1efb6659fa65b6af45db114b6621008f9abba64fad6820
+PKG_HASH:=803b360fdb6d5fde1e647bdc40c16de3031b1a95b347b48b65fe4fc27a548d4a
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
+PKG_BUILD_DEPENDS:=meson/host
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
+include ../../devel/meson/meson.mk
define Package/grilo-plugins/Default
SECTION:=multimedia
@@ -44,28 +45,23 @@ define Package/grilo/decription
plugins to get information from a number of sources.
endef
-CONFIGURE_ARGS += \
- --enable-static \
- --disable-compile-warnings \
- --disable-goa \
- --disable-filesystem \
- --disable-optical-media \
- --disable-youtube \
- --disable-flickr \
- --disable-podcasts \
- --disable-bookmarks \
- --disable-lua-factory \
- --disable-metadata-store \
- --disable-vimeo \
- --disable-tracker \
- --disable-local-metadata \
- --disable-chromaprint \
- --disable-thetvdb \
- --disable-tmdb \
- --disable-freebox
-
-MAKE_FLAGS += \
- GLIB_COMPILE_RESOURCES="$(STAGING_DIR_HOSTPKG)/bin/glib-compile-resources"
+MESON_ARGS += \
+ -Denable-filesystem=no \
+ -Denable-optical-media=no \
+ -Denable-youtube=no \
+ -Denable-flickr=no \
+ -Denable-podcasts=no \
+ -Denable-bookmarks=no \
+ -Denable-lua-factory=no \
+ -Denable-metadata-store=no \
+ -Denable-vimeo=no \
+ -Denable-tracker=no \
+ -Denable-local-metadata=no \
+ -Denable-chromaprint=no \
+ -Denable-thetvdb=no \
+ -Denable-tmdb=no \
+ -Denable-freebox=no \
+
define Package/grilo-plugins/install
$(INSTALL_DIR) $(1)/usr/lib/grilo-0.3
endef
diff --git a/multimedia/grilo-plugins/patches/001-no-help-po-tests.patch b/multimedia/grilo-plugins/patches/001-no-help-po-tests.patch
new file mode 100644
index 000000000..f711b53af
--- /dev/null
+++ b/multimedia/grilo-plugins/patches/001-no-help-po-tests.patch
@@ -0,0 +1,15 @@
+Fix build error on OpenWrt build servers. See:
+
+ https://github.com/openwrt/packages/pull/10433#issuecomment-549242840
+ https://github.com/mesonbuild/meson/issues/821
+
+diff -u --recursive grilo-plugins-0.3.10-vanilla/meson.build grilo-plugins-0.3.10/meson.build
+--- grilo-plugins-0.3.10-vanilla/meson.build 2019-09-12 11:48:29.000000000 -0400
++++ grilo-plugins-0.3.10/meson.build 2020-01-20 11:17:22.803149935 -0500
+@@ -173,6 +173,3 @@
+ rootdir = include_directories('.')
+
+ subdir('src')
+-subdir('help')
+-subdir('po')
+-subdir('tests')
diff --git a/multimedia/grilo-plugins/patches/001-remove-docs-gnome-from-configure.ac.patch b/multimedia/grilo-plugins/patches/001-remove-docs-gnome-from-configure.ac.patch
deleted file mode 100644
index 8fee0880c..000000000
--- a/multimedia/grilo-plugins/patches/001-remove-docs-gnome-from-configure.ac.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1316,7 +1316,7 @@ AC_SUBST(DEPS_OPENSUBTITLES_LIBS)
- # GETTEXT/INTLTOOL
- # ----------------------------------------------------------
-
--IT_PROG_INTLTOOL([0.40.0])
-+IT_PROG_INTLTOOL([0.40.0], [no-xml])
- GETTEXT_PACKAGE=grilo-plugins
- AC_SUBST(GETTEXT_PACKAGE)
- AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [The domain to use with gettext])
-@@ -1334,7 +1334,7 @@ AC_SUBST([builddir])
- # DOCUMENTATION
- # ----------------------------------------------------------
-
--YELP_HELP_INIT
-+#YELP_HELP_INIT
-
- # ----------------------------------------------------------
- # OUTPUT
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -10,7 +10,7 @@ include $(top_srcdir)/release.mk
-
- ACLOCAL_AMFLAGS = -I m4
-
--SUBDIRS = src help po tests
-+SUBDIRS = src po
-
- MAINTAINERCLEANFILES = \
- $(GITIGNORE_MAINTAINERCLEANFILES_TOPLEVEL) \
diff --git a/multimedia/grilo-plugins/src/m4/gnome-common.m4 b/multimedia/grilo-plugins/src/m4/gnome-common.m4
deleted file mode 100644
index a8d0fda43..000000000
--- a/multimedia/grilo-plugins/src/m4/gnome-common.m4
+++ /dev/null
@@ -1,32 +0,0 @@
-# gnome-common.m4
-#
-# serial 3
-#
-
-AU_DEFUN([GNOME_DEBUG_CHECK],
-[
- AX_CHECK_ENABLE_DEBUG([no],[GNOME_ENABLE_DEBUG])
-],
-[[$0: This macro is deprecated. You should use AX_CHECK_ENABLE_DEBUG instead and
-replace uses of GNOME_ENABLE_DEBUG with ENABLE_DEBUG.
-See: http://www.gnu.org/software/autoconf-archive/ax_check_enable_debug.html#ax_check_enable_debug]])
-
-dnl GNOME_MAINTAINER_MODE_DEFINES ()
-dnl define DISABLE_DEPRECATED
-dnl
-AU_DEFUN([GNOME_MAINTAINER_MODE_DEFINES],
-[
- AC_REQUIRE([AM_MAINTAINER_MODE])
-
- DISABLE_DEPRECATED=""
- if test $USE_MAINTAINER_MODE = yes; then
- DOMAINS="GCONF BONOBO BONOBO_UI GNOME LIBGLADE GNOME_VFS WNCK LIBSOUP"
- for DOMAIN in $DOMAINS; do
- DISABLE_DEPRECATED="$DISABLE_DEPRECATED -D${DOMAIN}_DISABLE_DEPRECATED -D${DOMAIN}_DISABLE_SINGLE_INCLUDES"
- done
- fi
-
- AC_SUBST(DISABLE_DEPRECATED)
-],
-[[$0: This macro is deprecated. All of the modules it disables deprecations for
-are obsolete. Remove it and all uses of DISABLE_DEPRECATED.]])
diff --git a/multimedia/grilo-plugins/src/m4/gnome-compiler-flags.m4 b/multimedia/grilo-plugins/src/m4/gnome-compiler-flags.m4
deleted file mode 100644
index 49ebb959b..000000000
--- a/multimedia/grilo-plugins/src/m4/gnome-compiler-flags.m4
+++ /dev/null
@@ -1,184 +0,0 @@
-# gnome-compiler-flags.m4
-#
-# serial 4
-#
-
-dnl GNOME_COMPILE_WARNINGS
-dnl Turn on many useful compiler warnings and substitute the result into
-dnl WARN_CFLAGS
-dnl For now, only works on GCC
-dnl Pass the default value of the --enable-compile-warnings configure option as
-dnl the first argument to the macro, defaulting to 'yes'.
-dnl Additional warning/error flags can be passed as an optional second argument.
-dnl
-dnl For example: GNOME_COMPILE_WARNINGS([maximum],[-Werror=some-flag -Wfoobar])
-AU_DEFUN([GNOME_COMPILE_WARNINGS],[
- dnl ******************************
- dnl More compiler warnings
- dnl ******************************
-
- AC_ARG_ENABLE(compile-warnings,
- AS_HELP_STRING([--enable-compile-warnings=@<:@no/minimum/yes/maximum/error@:>@],
- [Turn on compiler warnings]),,
- [enable_compile_warnings="m4_default([$1],[yes])"])
-
- if test "x$GCC" != xyes; then
- enable_compile_warnings=no
- fi
-
- warning_flags=
- realsave_CFLAGS="$CFLAGS"
-
- dnl These are warning flags that aren't marked as fatal. Can be
- dnl overridden on a per-project basis with -Wno-foo.
- base_warn_flags=" \
- -Wall \
- -Wstrict-prototypes \
- -Wnested-externs \
- "
-
- dnl These compiler flags typically indicate very broken or suspicious
- dnl code. Some of them such as implicit-function-declaration are
- dnl just not default because gcc compiles a lot of legacy code.
- dnl We choose to make this set into explicit errors.
- base_error_flags=" \
- -Werror=missing-prototypes \
- -Werror=implicit-function-declaration \
- -Werror=pointer-arith \
- -Werror=init-self \
- -Werror=format-security \
- -Werror=format=2 \
- -Werror=missing-include-dirs \
- -Werror=return-type \
- "
-
- dnl Additional warning or error flags provided by the module author to
- dnl allow stricter standards to be imposed on a per-module basis.
- dnl The author can pass -W or -Werror flags here as they see fit.
- additional_flags="m4_default([$2],[])"
-
- case "$enable_compile_warnings" in
- no)
- warning_flags="-w"
- ;;
- minimum)
- warning_flags="-Wall"
- ;;
- yes|maximum|error)
- warning_flags="$base_warn_flags $base_error_flags $additional_flags"
- ;;
- *)
- AC_MSG_ERROR(Unknown argument '$enable_compile_warnings' to --enable-compile-warnings)
- ;;
- esac
-
- if test "$enable_compile_warnings" = "error" ; then
- warning_flags="$warning_flags -Werror"
- fi
-
- dnl Check whether GCC supports the warning options
- for option in $warning_flags; do
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $option"
- AC_MSG_CHECKING([whether gcc understands $option])
- AC_TRY_COMPILE([], [],
- has_option=yes,
- has_option=no,)
- CFLAGS="$save_CFLAGS"
- AC_MSG_RESULT([$has_option])
- if test $has_option = yes; then
- tested_warning_flags="$tested_warning_flags $option"
- fi
- unset has_option
- unset save_CFLAGS
- done
- unset option
- CFLAGS="$realsave_CFLAGS"
- AC_MSG_CHECKING(what warning flags to pass to the C compiler)
- AC_MSG_RESULT($tested_warning_flags)
-
- AC_ARG_ENABLE(iso-c,
- AS_HELP_STRING([--enable-iso-c],
- [Try to warn if code is not ISO C ]),,
- [enable_iso_c=no])
-
- AC_MSG_CHECKING(what language compliance flags to pass to the C compiler)
- complCFLAGS=
- if test "x$enable_iso_c" != "xno"; then
- if test "x$GCC" = "xyes"; then
- case " $CFLAGS " in
- *[\ \ ]-ansi[\ \ ]*) ;;
- *) complCFLAGS="$complCFLAGS -ansi" ;;
- esac
- case " $CFLAGS " in
- *[\ \ ]-pedantic[\ \ ]*) ;;
- *) complCFLAGS="$complCFLAGS -pedantic" ;;
- esac
- fi
- fi
- AC_MSG_RESULT($complCFLAGS)
-
- WARN_CFLAGS="$tested_warning_flags $complCFLAGS"
- AC_SUBST(WARN_CFLAGS)
-],
-[[$0: This macro is deprecated. You should use AX_COMPILER_FLAGS instead and
-eliminate use of --enable-iso-c.
-See: http://www.gnu.org/software/autoconf-archive/ax_compiler_flags.html#ax_compiler_flags]])
-
-dnl For C++, do basically the same thing.
-
-AU_DEFUN([GNOME_CXX_WARNINGS],[
- AC_ARG_ENABLE(cxx-warnings,
- AS_HELP_STRING([--enable-cxx-warnings=@<:@no/minimum/yes@:>@]
- [Turn on compiler warnings.]),,
- [enable_cxx_warnings="m4_default([$1],[minimum])"])
-
- AC_MSG_CHECKING(what warning flags to pass to the C++ compiler)
- warnCXXFLAGS=
- if test "x$GXX" != xyes; then
- enable_cxx_warnings=no
- fi
- if test "x$enable_cxx_warnings" != "xno"; then
- if test "x$GXX" = "xyes"; then
- case " $CXXFLAGS " in
- *[\ \ ]-Wall[\ \ ]*) ;;
- *) warnCXXFLAGS="-Wall -Wno-unused" ;;
- esac
-
- ## -W is not all that useful. And it cannot be controlled
- ## with individual -Wno-xxx flags, unlike -Wall
- if test "x$enable_cxx_warnings" = "xyes"; then
- warnCXXFLAGS="$warnCXXFLAGS -Wshadow -Woverloaded-virtual"
- fi
- fi
- fi
- AC_MSG_RESULT($warnCXXFLAGS)
-
- AC_ARG_ENABLE(iso-cxx,
- AS_HELP_STRING([--enable-iso-cxx],
- [Try to warn if code is not ISO C++ ]),,
- [enable_iso_cxx=no])
-
- AC_MSG_CHECKING(what language compliance flags to pass to the C++ compiler)
- complCXXFLAGS=
- if test "x$enable_iso_cxx" != "xno"; then
- if test "x$GXX" = "xyes"; then
- case " $CXXFLAGS " in
- *[\ \ ]-ansi[\ \ ]*) ;;
- *) complCXXFLAGS="$complCXXFLAGS -ansi" ;;
- esac
-
- case " $CXXFLAGS " in
- *[\ \ ]-pedantic[\ \ ]*) ;;
- *) complCXXFLAGS="$complCXXFLAGS -pedantic" ;;
- esac
- fi
- fi
- AC_MSG_RESULT($complCXXFLAGS)
-
- WARN_CXXFLAGS="$CXXFLAGS $warnCXXFLAGS $complCXXFLAGS"
- AC_SUBST(WARN_CXXFLAGS)
-],
-[[$0: This macro is deprecated. You should use AX_COMPILER_FLAGS instead and
-eliminate use of --enable-iso-cxx.
-See: http://www.gnu.org/software/autoconf-archive/ax_compiler_flags.html#ax_compiler_flags]])