aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-12-26 22:47:25 +0200
committerGitHub <noreply@github.com>2018-12-26 22:47:25 +0200
commit97836d987f87593e24f70bff96709d15c53cb359 (patch)
treea36cda33766048882dbefb5caeccdf825f3faf16 /mail
parent71953c566a51014ef9d626b0d9ea13c354271aca (diff)
parente605a1fa9976c06117ac7c9b79fc8feb6e72cd8c (diff)
Merge pull request #7656 from neheb/msm
msmtp: Update to 1.8.1
Diffstat (limited to 'mail')
-rw-r--r--mail/msmtp/Makefile16
-rw-r--r--mail/msmtp/patches/010-openssl-deprecated.patch42
2 files changed, 8 insertions, 50 deletions
diff --git a/mail/msmtp/Makefile b/mail/msmtp/Makefile
index 2c9ec3249..12a36dbda 100644
--- a/mail/msmtp/Makefile
+++ b/mail/msmtp/Makefile
@@ -9,22 +9,21 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=msmtp
-PKG_VERSION:=1.6.8
-PKG_RELEASE:=2
+PKG_VERSION:=1.8.1
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://marlam.de/msmtp/releases
-PKG_HASH:=55ff95a304d888b56d07d9c62327ab9bfe26532c9c2a2ed6aefc43bea1b659fb
+PKG_HASH:=f0a2a7ed23a3ba5ca88640a9bc433507a79fdfc916b14a989d36679b7fdca4da
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
PKG_LICENSE:=GPL-3.0+
PKG_LICENSE_FILES:=COPYING
-PKG_MAINTAINER:=
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -46,7 +45,7 @@ endef
define Package/msmtp
$(call Package/msmtp/Default)
- DEPENDS+= +libopenssl +ca-bundle
+ DEPENDS+= +libgnutls +ca-bundle
TITLE+= (with SSL support)
VARIANT:=ssl
endef
@@ -101,6 +100,7 @@ CONFIGURE_ARGS += \
--without-libidn \
--without-libsecret \
--without-macosx-keyring \
+ --without-msmtpd
ifneq ($(CONFIG_USE_UCLIBC),)
CONFIGURE_ARGS += --disable-gai-idn
@@ -110,7 +110,7 @@ MAKE_FLAGS :=
ifeq ($(BUILD_VARIANT),ssl)
CONFIGURE_ARGS += \
- --with-tls=openssl
+ --with-tls=gnutls
endif
ifeq ($(BUILD_VARIANT),nossl)
diff --git a/mail/msmtp/patches/010-openssl-deprecated.patch b/mail/msmtp/patches/010-openssl-deprecated.patch
deleted file mode 100644
index 2a229aad5..000000000
--- a/mail/msmtp/patches/010-openssl-deprecated.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- a/src/tls.c
-+++ b/src/tls.c
-@@ -45,6 +45,10 @@
- # include <openssl/err.h>
- # include <openssl/rand.h>
- # include <openssl/evp.h>
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#define X509_getm_notBefore X509_get_notBefore
-+#define X509_getm_notAfter X509_get_notAfter
-+#endif
- #endif /* HAVE_LIBSSL */
-
- #ifdef HAVE_LIBIDN
-@@ -167,8 +171,10 @@ int tls_lib_init(char **errstr)
- #ifdef HAVE_LIBSSL
- int e;
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- SSL_load_error_strings();
- SSL_library_init();
-+#endif
- if ((e = seed_prng(errstr)) != TLS_EOK)
- {
- return e;
-@@ -518,7 +524,7 @@ int tls_cert_info_get(tls_t *tls, tls_cert_info_t *tci, char **errstr)
- *errstr = xasprintf(_("%s: error getting SHA1 fingerprint"), errmsg);
- return TLS_ECERT;
- }
-- asn1time = X509_get_notBefore(x509cert);
-+ asn1time = X509_getm_notBefore(x509cert);
- if (asn1time_to_time_t((char *)asn1time->data,
- (asn1time->type != V_ASN1_GENERALIZEDTIME),
- &(tci->activation_time)) != 0)
-@@ -528,7 +534,7 @@ int tls_cert_info_get(tls_t *tls, tls_cert_info_t *tci, char **errstr)
- tls_cert_info_free(tci);
- return TLS_ECERT;
- }
-- asn1time = X509_get_notAfter(x509cert);
-+ asn1time = X509_getm_notAfter(x509cert);
- if (asn1time_to_time_t((char *)asn1time->data,
- (asn1time->type != V_ASN1_GENERALIZEDTIME),
- &(tci->expiration_time)) != 0)