aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2017-12-02 14:09:39 -0800
committerGitHub <noreply@github.com>2017-12-02 14:09:39 -0800
commit8dc8716e74f773cf1c2e894069b44befa2b1f0c0 (patch)
tree5f211d095b6594c809d5873bd8da826c36687bf3 /mail
parenta9f30ca5a60898a5a2b58e13b762a40566a519b7 (diff)
parent6c6a40ab57d1151f981237f81935b19486c45026 (diff)
Merge pull request #5183 from val-kulkov/pigeonhole-package
pigeonhole: fix runtime dependency on dovecot's ABI
Diffstat (limited to 'mail')
-rw-r--r--mail/pigeonhole/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/mail/pigeonhole/Makefile b/mail/pigeonhole/Makefile
index d136b2a89..6e52f142a 100644
--- a/mail/pigeonhole/Makefile
+++ b/mail/pigeonhole/Makefile
@@ -7,50 +7,52 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=pigeonhole
-PKG_VERSION:=0.4.20
-PKG_RELEASE:=1
+PKG_NAME:=dovecot-pigeonhole
+PKG_VERSION_PLUGIN:=0.4.20
+PKG_VERSION_DOVECOT:=$(shell make --no-print-directory -C ../dovecot/ val.PKG_VERSION V=s)
+PKG_VERSION:=$(PKG_VERSION_DOVECOT)-$(PKG_VERSION_PLUGIN)
+PKG_RELEASE:=2
DOVECOT_VERSION:=2.2
-PKG_SOURCE:=dovecot-$(DOVECOT_VERSION)-$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=dovecot-$(DOVECOT_VERSION)-pigeonhole-$(PKG_VERSION_PLUGIN).tar.gz
PKG_SOURCE_URL:=https://pigeonhole.dovecot.org/releases/$(DOVECOT_VERSION)
PKG_HASH:=6fe17d0b8f25f2ad580e01ad81ce47a9e965255e383a1f80e455f9ca0f00be5b
PKG_LICENSE:=LGPL-2.1
PKG_LICENSE_FILES:=COPYING COPYING.LGPL
-PKG_BUILD_DIR:=$(BUILD_DIR)/dovecot-$(DOVECOT_VERSION)-$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/dovecot-$(DOVECOT_VERSION)-pigeonhole-$(PKG_VERSION_PLUGIN)
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
-define Package/pigeonhole
+define Package/dovecot-pigeonhole
SECTION:=mail
CATEGORY:=Mail
DEPENDS:=+dovecot
+ EXTRA_DEPENDS:=dovecot (>= $(PKG_VERSION_DOVECOT))
TITLE:=Mail filtering facilities for Dovecot
MAINTAINER:=W. Michael Petullo <mike@flyn.org>
URL:=https://wiki2.dovecot.org/Pigeonhole
endef
-define Package/pigeonhole/description
+define Package/dovecot-pigeonhole/description
Pigeonhole provides mail filtering facilities for Dovecot using the Sieve
(RFC 5228) language.
endef
CONFIGURE_ARGS += \
- --with-dovecot=$(STAGING_DIR)/usr/lib/dovecot/ \
- --without-managesieve
+ --with-dovecot=$(STAGING_DIR)/usr/lib/dovecot/
CONFIGURE_VARS += \
LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/dovecot/" \
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/dovecot/"
-define Package/pigeonhole/install
+define Package/dovecot-pigeonhole/install
$(INSTALL_DIR) $(1)/usr/bin $(1)/usr/lib/dovecot/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/dovecot/* $(1)/usr/lib/dovecot/
find $(1)/usr/lib/dovecot/ -name "*.a" -o -name "*.la" | xargs rm
endef
-$(eval $(call BuildPackage,pigeonhole))
+$(eval $(call BuildPackage,dovecot-pigeonhole))