aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2017-03-08 02:02:03 +0200
committerLucian Cristian <lucian.cristian@gmail.com>2017-03-08 02:02:03 +0200
commit2fdca4d5a58a52d079912ad7a50dc442820e5bbd (patch)
tree63e6e75caef3e379d83ecb5728f437454085c86f /mail
parent154a0da7244316863ab72b74dbee32ccc3074026 (diff)
postfix: Add SQLite support
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'mail')
-rw-r--r--mail/postfix/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 8801948dc..7b6b7664b 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=postfix
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=ftp://ftp.porcupine.org/mirrors/postfix-release/official/
PKG_VERSION:=3.1.4
PKG_MD5SUM:=878a059d92ee3b093d7d3e97248c915d
@@ -25,7 +25,7 @@ define Package/postfix
CATEGORY:=Mail
TITLE:=Postfix Mail Transmit Agent
URL:=http://www.postfix.org/
- DEPENDS:=+POSTFIX_TLS:libopenssl +POSTFIX_SASL:libsasl2 +POSTFIX_LDAP:libopenldap +POSTFIX_DB:libdb47 +POSTFIX_EAI:icu +libpcre
+ DEPENDS:=+POSTFIX_TLS:libopenssl +POSTFIX_SASL:libsasl2 +POSTFIX_LDAP:libopenldap +POSTFIX_DB:libdb47 +POSTFIX_SQLITE:libsqlite3 +POSTFIX_EAI:icu +libpcre
endef
define Package/postfix/description
@@ -59,6 +59,11 @@ define Package/postfix/config
default y
help
Implements support for cdb files using tinycdb
+ config POSTFIX_SQLITE
+ bool "SQLITE support"
+ default y
+ help
+ Implements support for SQLite3 DB
config POSTFIX_EAI
bool "SMTPUTF8 support"
default n
@@ -106,6 +111,11 @@ else
CCARGS+=-DNO_DB
endif
+ifdef CONFIG_POSTFIX_SQLITE
+ CCARGS+=-DHAS_SQLITE -I$(STAGING_DIR)/usr/include/
+ AUXLIBS+=-L$(STAGING_DIR)/usr/lib -lsqlite3 -lpthread
+endif
+
ifdef CONFIG_POSTFIX_EAI
AUXLIBS+=-licuuc
CCARGS+=-DHAS_EAI