aboutsummaryrefslogtreecommitdiff
path: root/mail/sendmail
diff options
context:
space:
mode:
authorGuo Li <uxgood.org@gmail.com>2018-09-26 12:14:10 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2018-09-26 16:28:48 +0800
commitcbc948acf3c46d01336990fa6c68152b7efea227 (patch)
tree6edd84a9f3c5ec431e62c71f2b6f5170bec1687a /mail/sendmail
parent1166618115f72d61e2e5c59ecbfe89607ade23bf (diff)
sendmail: fix confLIBSEARCHPATH to $(STAGING_DIR)
This fix issue 'cannot find -lnsl' on build server which has libnsl.so in /usr/lib Signed-off-by: Guo Li <uxgood.org@gmail.com>
Diffstat (limited to 'mail/sendmail')
-rw-r--r--mail/sendmail/Makefile3
-rw-r--r--mail/sendmail/files/OpenWrt3
2 files changed, 4 insertions, 2 deletions
diff --git a/mail/sendmail/Makefile b/mail/sendmail/Makefile
index 818fb1e6a..824ea9760 100644
--- a/mail/sendmail/Makefile
+++ b/mail/sendmail/Makefile
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sendmail
PKG_VERSION:=8.15.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://artfiles.org/sendmail.org/pub/sendmail/ \
@@ -102,6 +102,7 @@ define Build/Prepare
$(CP) $(PKG_BUILD_DIR)/cf/cf/generic-linux.mc $(PKG_BUILD_DIR)/cf/cf/sendmail.mc
$(SED) 's@TARGET_CC@$(TARGET_CC)@g' $(PKG_BUILD_DIR)/devtools/Site/$(SITECONFIG)
$(SED) 's@TARGET_CFLAGS@$(TARGET_CFLAGS)@g' $(PKG_BUILD_DIR)/devtools/Site/$(SITECONFIG)
+ $(SED) 's@STAGING_DIR@$(STAGING_DIR)@g' $(PKG_BUILD_DIR)/devtools/OS/$(TARGET_OS)
endef
define Build/Compile
diff --git a/mail/sendmail/files/OpenWrt b/mail/sendmail/files/OpenWrt
index bdcaad283..00865f018 100644
--- a/mail/sendmail/files/OpenWrt
+++ b/mail/sendmail/files/OpenWrt
@@ -7,7 +7,8 @@ define(`confSM_OS_HEADER', `sm_os_linux')
define(`confLIBS', `-ldl')
define(`confEBINDIR', `/usr/sbin')
define(`confMKDIR', `mkdir')
-APPENDDEF(`confLIBSEARCH', `crypt nsl')
+define(`confLIBSEARCHPATH', `STAGING_DIR/lib STAGING_DIR/usr/lib')
+APPENDDEF(`confLIBSEARCH', `crypt')
define(`confMTCCOPTS', `-D_REENTRANT')
define(`confMTLDOPTS', `-lpthread')