aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt
diff options
context:
space:
mode:
authorPhil Eichinger <phil@zankapfel.net>2015-11-18 18:08:08 +0100
committerPhil Eichinger <phil@zankapfel.net>2015-11-30 07:14:58 +0100
commit726a734c32b130b9779258f96643f74ea73997c4 (patch)
tree04d16ddc0799cac2283bee96c994dae7182cc2e9 /mail/mutt
parent84344880b975c7a34e7ea9758ba853bf5e08a908 (diff)
mutt: bring back from oldpackages
* import from oldpackages * bump version and update hash * update patch to new version * add PKG_LICENSE, PKG_LICENSE_FILES, PKG_MAINTAINER Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Diffstat (limited to 'mail/mutt')
-rw-r--r--mail/mutt/Makefile53
-rw-r--r--mail/mutt/patches/0001-no-po-and-docs.patch27
2 files changed, 80 insertions, 0 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
new file mode 100644
index 000000000..dca6cb529
--- /dev/null
+++ b/mail/mutt/Makefile
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mutt
+PKG_VERSION:=1.5.24
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=ftp://ftp.mutt.org/pub/mutt/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=7f25d27f3c7c82285ac07aac35f5f0f2
+
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=GPL
+PKG_MAINTAINER=Phil Eichinger <phil@zankapfel.net>
+
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/mutt
+ SECTION:=mail
+ CATEGORY:=Mail
+ DEPENDS:=+libopenssl +libncursesw
+ TITLE:=Console mail client
+ URL:=http://www.mutt.org/
+endef
+
+define Package/mutt/description
+ Mutt is a small but very powerful text-based mail client for Unix
+ operating systems.
+endef
+
+CONFIGURE_ARGS += \
+ --includedir=$(PKG_BUILD_DIR)/. \
+ --oldincludedir=$(PKG_BUILD_DIR)/. \
+ --enable-pop \
+ --enable-imap \
+ --with-ssl \
+ --without-idn
+
+define Package/mutt/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mutt $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,mutt))
diff --git a/mail/mutt/patches/0001-no-po-and-docs.patch b/mail/mutt/patches/0001-no-po-and-docs.patch
new file mode 100644
index 000000000..607e441f6
--- /dev/null
+++ b/mail/mutt/patches/0001-no-po-and-docs.patch
@@ -0,0 +1,27 @@
+From b0e285a8c7faaec8807fdd677da6750f341f0109 Mon Sep 17 00:00:00 2001
+From: Phil Eichinger <phil@zankapfel.net>
+Date: Thu, 19 Nov 2015 13:18:53 +0100
+Subject: [PATCH] no po and docs
+
+[adapted old patch and converted to git patch]
+Signed-off-by: Phil Eichinger <phil@zankapfel.net>
+---
+ Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 1909835..cfa7ca0 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -458,7 +458,7 @@ get_cs_cmdline = $(call get_cs_compile,$(1)) $(call get_cs_all_flags,$(1),check_
+ AUTOMAKE_OPTIONS = 1.6 foreign
+ @BUILD_IMAP_TRUE@IMAP_SUBDIR = imap
+ @BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap
+-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
++SUBDIRS = m4 intl contrib $(IMAP_SUBDIR)
+ bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
+ @BUILD_HCACHE_TRUE@HCVERSION = hcversion.h
+ BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION)
+--
+2.1.4
+