aboutsummaryrefslogtreecommitdiff
path: root/mail/mutt/Makefile
diff options
context:
space:
mode:
authorPhil Eichinger <phil@zankapfel.net>2017-10-17 16:37:38 +0200
committerPhil Eichinger <phil@zankapfel.net>2017-10-18 16:27:25 +0200
commitad25e99fefd882b2995ff567db00e95a7649384a (patch)
tree060de424510b81d6a3d16cb1aaa36e97141f98eb /mail/mutt/Makefile
parent4317fe0a10ddb6a3dfc4b88e42b74546aa8b9f89 (diff)
mutt: bump version
* no-po-no-docs patch reworked, docs are disabled via ./configure now * drop CVE patch, fix already in upstream * autoreconf to fix CI build Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Diffstat (limited to 'mail/mutt/Makefile')
-rw-r--r--mail/mutt/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 8da33ecb6..2621c768d 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -8,18 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mutt
-PKG_VERSION:=1.7.2
+PKG_VERSION:=1.9.1
PKG_RELEASE:=1
PKG_SOURCE_URL:=ftp://ftp.mutt.org/pub/mutt/ \
https://bitbucket.org/mutt/mutt/downloads/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=1553501687cd22d5b8aaee4dc5a7d9dcf6cc61d7956f6aabaadd252d10cd5ff9
+PKG_HASH:=749b83a96373c6e2101ebe8c4b9a651735e02c478edb750750a5146a15d91bb1
PKG_LICENSE:=GPL-2.0+
PKG_LICENSE_FILES:=GPL
PKG_MAINTAINER:=Phil Eichinger <phil@zankapfel.net>
+PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
@@ -44,7 +45,8 @@ CONFIGURE_ARGS += \
--enable-pop \
--enable-imap \
--with-ssl \
- --without-idn
+ --without-idn \
+ --disable-doc
define Package/mutt/install
$(INSTALL_DIR) $(1)/usr/bin