aboutsummaryrefslogtreecommitdiff
path: root/mail/emailrelay/Makefile
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2019-10-13 01:00:20 +0800
committerJeffery To <jeffery.to@gmail.com>2019-10-13 02:01:34 +0800
commit53e1692ae91b1b5fc59a7e8ab7fb98f8775eb4b6 (patch)
tree49a758e5d65104f3f86247868009c5774d39e04b /mail/emailrelay/Makefile
parent7de37d7fea41a285c57a9593612548cd8b509ec0 (diff)
treewide: Use default PKG_BUILD_DIR when possible
This removes lines that set PKG_BUILD_DIR when the set value is no different from the default value. Specifically, the line is removed if the assigned value is: * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION) The default PKG_BUILD_DIR was updated[1] to incorporate BUILD_VARIANT if it is set, so now this is identical to the default value. * $(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_SOURCE_SUBDIR) if PKG_SOURCE_SUBDIR is set to $(PKG_NAME)-$(PKG_VERSION), making it the same as the previous case * $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) This is the same as the default PKG_BUILD_DIR when there is no BUILD_VARIANT. * $(BUILD_DIR)/[name]-$(PKG_VERSION) where [name] is a string that is identical to PKG_NAME [1]: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=e545fac8d968864a965edb9e50c6f90940b0a6c9 Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'mail/emailrelay/Makefile')
-rw-r--r--mail/emailrelay/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/mail/emailrelay/Makefile b/mail/emailrelay/Makefile
index cef6e22c0..089abb323 100644
--- a/mail/emailrelay/Makefile
+++ b/mail/emailrelay/Makefile
@@ -16,8 +16,6 @@ PKG_SOURCE_URL:=@SF/emailrelay/$(PKG_VERSION)
PKG_HASH:=0b3a98edfdc8deaf2b3d14e2d2a7fa8402f6703d83ac7458653994124de6a587
PKG_MAINTAINER:=Federico Di Marco <fededim@gmail.com>
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-
PKG_CONFIG_DEPENDS:=CONFIG_EMAILRELAY_SUPPORT_VERBOSE_DBG CONFIG_EMAILRELAY_SSL
PKG_LICENSE:=GPL-3.0