aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLucian Cristian <lucian.cristian@gmail.com>2017-03-08 01:42:50 +0200
committerLucian Cristian <lucian.cristian@gmail.com>2017-03-08 01:42:50 +0200
commit6bbbf29a8561f02ce8ee2338a820fb4c2ee8037e (patch)
tree45a92b32f08b83db10ee5e6afe41832e7d0671bb /mail/dovecot
parentdb86cdb3f7428686e393a89207d3006dd9cfd3f1 (diff)
dovecot: add SQLite support
Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index fdc5dfbe1..ba4a322cb 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/dovecot
SECTION:=mail
CATEGORY:=Mail
- DEPENDS:=+DOVECOT_LDAP:libopenldap +libopenssl +librt +zlib +libbz2 +libcap
+ DEPENDS:=+DOVECOT_LDAP:libopenldap DOVECOT_SQLITE:libsqlite3 +libopenssl +librt +zlib +libbz2 +libcap
TITLE:=An IMAP and POP3 daemon
MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
URL:=http://www.dovecot.org/
@@ -46,6 +46,11 @@ define Package/dovecot/config
default n
help
Implements LDAP support in dovecot.
+ config DOVECOT_SQLITE
+ bool "SQLite support"
+ default n
+ help
+ Implements SQLite DB support in dovecot.
endmenu
endef
@@ -57,7 +62,8 @@ CONFIGURE_ARGS += \
--without-lzma \
--without-lz4 \
--with-icu=no \
- $(if $(CONFIG_DOVECOT_LDAP),--with-ldap=yes,--with-ldap=no)
+ $(if $(CONFIG_DOVECOT_LDAP),--with-ldap=yes,--with-ldap=no) \
+ $(if $(CONFIG_DOVECOT_SQLITE),--with-sqlite=yes,--with-sqlite=no)
CONFIGURE_VARS += \
RPCGEN= \