aboutsummaryrefslogtreecommitdiff
path: root/mail/bogofilter
diff options
context:
space:
mode:
authorW. Michael Petullo <mike@flyn.org>2014-10-13 17:54:53 -0400
committerW. Michael Petullo <mike@flyn.org>2014-10-13 17:54:53 -0400
commit665c5ee68be2abc9665bc6a07a70b3f125c8f398 (patch)
tree1b4033d6371aac895b32d1b4fad0b28fa53b198e /mail/bogofilter
parentf0a7ad87dd5b4bfe4da6f81bc9484667cd5c009e (diff)
bogofilter: new package for bogofilter spam filter
Signed-off-by: W. Michael Petullo <mike@flyn.org>
Diffstat (limited to 'mail/bogofilter')
-rw-r--r--mail/bogofilter/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
new file mode 100644
index 000000000..076e3dcc9
--- /dev/null
+++ b/mail/bogofilter/Makefile
@@ -0,0 +1,53 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bogofilter
+PKG_VERSION:=1.2.4
+PKG_RELEASE:=1
+
+PKG_LICENSE:=GPLv2
+PKG_LICENSE_FILE:=COPYING
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/bogofilter
+PKG_MD5SUM:=d0a5eebb3274b23ceabe766a6443a1c5
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bogofilter
+ SECTION:=mail
+ CATEGORY:=Mail
+ DEPENDS:=+libdb47
+ TITLE:=bogofilter
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+ URL:=http://bogofilter.sourceforge.net/
+endef
+
+define Package/bogofilter/description
+ Bogofilter is a fast Bayesian spam filter
+endef
+
+CONFIGURE_ARGS += --disable-unicode
+
+define Package/bogofilter/install
+ $(INSTALL_DIR) $(1)/etc/ \
+ $(1)/usr/bin
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/bogofilter.cf.example $(1)/etc/bogofilter.cf
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bf_compact $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bf_copy $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bf_tar $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bogofilter $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bogolexer $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bogotune $(1)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/bogoutil $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,bogofilter))