aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2020-06-01 22:48:16 +0800
committerRosen Penev <rosenp@gmail.com>2020-06-29 15:15:29 -0700
commitfe734cc26403e7c29a2d0a3432c246f118827c92 (patch)
treef7c38256566d966b7b97cb90f4ed3b116957457c /libs
parentc11726f14a996e9085ef5d6cb785e8c5f2c4e174 (diff)
gdbm: fix GCC 10 multiple def compilation error
Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/gdbm/Makefile2
-rw-r--r--libs/gdbm/patches/999-001-fix-multiple-def-gcc-10.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/gdbm/Makefile b/libs/gdbm/Makefile
index 2adcb31da..11f8c049f 100644
--- a/libs/gdbm/Makefile
+++ b/libs/gdbm/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gdbm
PKG_VERSION:=1.18.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/gdbm
diff --git a/libs/gdbm/patches/999-001-fix-multiple-def-gcc-10.patch b/libs/gdbm/patches/999-001-fix-multiple-def-gcc-10.patch
new file mode 100644
index 000000000..5ccb395fd
--- /dev/null
+++ b/libs/gdbm/patches/999-001-fix-multiple-def-gcc-10.patch
@@ -0,0 +1,11 @@
+--- a/src/parseopt.c
++++ b/src/parseopt.c
+@@ -255,8 +255,6 @@ print_option_descr (const char *descr, s
+ }
+
+ char *parseopt_program_name;
+-char *parseopt_program_doc;
+-char *parseopt_program_args;
+ const char *program_bug_address = "<" PACKAGE_BUGREPORT ">";
+ void (*parseopt_help_hook) (FILE *stream);
+