aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-08-21 11:42:04 -0700
committerRosen Penev <rosenp@gmail.com>2021-08-24 19:16:04 -0700
commitf8908827529df077d4c6feb2d17093eabc484358 (patch)
treead1dc90405571f7b18f1cf7fb6386eddf067897e /libs
parentef8c9641511dfea8fa1a951199eb477678129043 (diff)
spdlog: update to 1.9.2
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/spdlog/Makefile4
-rw-r--r--libs/spdlog/patches/010-fmt8.patch11
2 files changed, 2 insertions, 13 deletions
diff --git a/libs/spdlog/Makefile b/libs/spdlog/Makefile
index b3ee4e08e..94001690d 100644
--- a/libs/spdlog/Makefile
+++ b/libs/spdlog/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=spdlog
-PKG_VERSION:=1.8.5
+PKG_VERSION:=1.9.2
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/gabime/spdlog/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=944d0bd7c763ac721398dca2bb0f3b5ed16f67cef36810ede5061f35a543b4b8
+PKG_HASH:=6fff9215f5cb81760be4cc16d033526d1080427d236e86d70bb02994f85e3d38
PKG_MAINTAINER:=
PKG_LICENSE:=MIT
diff --git a/libs/spdlog/patches/010-fmt8.patch b/libs/spdlog/patches/010-fmt8.patch
deleted file mode 100644
index a9c0df59e..000000000
--- a/libs/spdlog/patches/010-fmt8.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/spdlog/common-inl.h
-+++ b/include/spdlog/common-inl.h
-@@ -60,7 +60,7 @@ SPDLOG_INLINE spdlog_ex::spdlog_ex(std::
- SPDLOG_INLINE spdlog_ex::spdlog_ex(const std::string &msg, int last_errno)
- {
- memory_buf_t outbuf;
-- fmt::format_system_error(outbuf, last_errno, msg);
-+ fmt::format_system_error(outbuf, last_errno, msg.data());
- msg_ = fmt::to_string(outbuf);
- }
-