aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2018-05-28 21:14:34 -0700
committerRosen Penev <rosenp@gmail.com>2018-05-29 18:31:20 -0700
commitf51d3846d8d5320d08f620c6a5d28fb3d7cb1fae (patch)
treec6289fd5e0d7ce5a2f3d466955cea3af48b85342 /libs
parentbcb725fe402b25748211f5576f41f92a1c08356c (diff)
libshout: Fix OpenSSL 1.1.0 without deprecated APIs
Previous patch was incomplete and broke with deprecated APIs disabled. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libshout/Makefile2
-rw-r--r--libs/libshout/patches/150-openssl-1.1.patch10
2 files changed, 9 insertions, 3 deletions
diff --git a/libs/libshout/Makefile b/libs/libshout/Makefile
index 83d527485..101f3c0db 100644
--- a/libs/libshout/Makefile
+++ b/libs/libshout/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libshout
PKG_VERSION:=2.4.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/libs/libshout/patches/150-openssl-1.1.patch b/libs/libshout/patches/150-openssl-1.1.patch
index 77ee83294..6028919ca 100644
--- a/libs/libshout/patches/150-openssl-1.1.patch
+++ b/libs/libshout/patches/150-openssl-1.1.patch
@@ -1,6 +1,8 @@
+diff --git a/src/tls.c b/src/tls.c
+index 4562c73..f946946 100644
--- a/src/tls.c
+++ b/src/tls.c
-@@ -63,10 +63,12 @@ static inline int tls_setup(shout_tls_t
+@@ -63,12 +63,16 @@ static inline int tls_setup(shout_tls_t *tls)
{
SSL_METHOD *meth;
@@ -9,7 +11,11 @@
SSL_load_error_strings();
SSLeay_add_all_algorithms();
SSLeay_add_ssl_algorithms();
-+#endif
meth = TLSv1_client_method();
++#else
++ meth = TLS_client_method();
++#endif
if (!meth)
+ goto error;
+