aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-30 16:46:31 -0700
committerGitHub <noreply@github.com>2020-03-30 16:46:31 -0700
commitedb929bf5bf5a0d7fc9c32cf9ba08aaaf0033dbf (patch)
treed685554e07c7016bc81a0fb78842b990a598f56f /libs
parent524b36c7d85e933330a1a37a8b92f89d69346381 (diff)
parentffb7da67a3e5858733031dc1b7012fafeb06515c (diff)
Merge pull request #11694 from neheb/v4l
libv4l: fix compilation with newer musl
Diffstat (limited to 'libs')
2 files changed, 12 insertions, 1 deletions
diff --git a/libs/libv4l/Makefile b/libs/libv4l/Makefile
index a58b8ff01..21fc5b9c2 100644
--- a/libs/libv4l/Makefile
+++ b/libs/libv4l/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.16.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
diff --git a/libs/libv4l/patches/040-musl.patch b/libs/libv4l/patches/040-musl.patch
new file mode 100644
index 000000000..79dc5d212
--- /dev/null
+++ b/libs/libv4l/patches/040-musl.patch
@@ -0,0 +1,11 @@
+--- a/utils/keytable/keytable.c
++++ b/utils/keytable/keytable.c
+@@ -1686,7 +1686,7 @@ static void test_event(struct rc_device *rc_dev, int fd)
+
+ for (i = 0; i < rd / sizeof(struct input_event); i++) {
+ printf(_("%ld.%06ld: event type %s(0x%02x)"),
+- ev[i].time.tv_sec, ev[i].time.tv_usec,
++ ev[i].input_event_sec, ev[i].input_event_usec,
+ get_event_name(events_type, ev[i].type), ev[i].type);
+
+ switch (ev[i].type) {