aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2014-08-07 13:09:39 -0400
committerTed Hess <thess@kitschensync.net>2014-08-07 13:09:39 -0400
commitd54d7c29a5993e5bf785d3d61d10ff31034f204a (patch)
tree5a66291332ef09f2e8228e3f14568fd2816dba4c /libs
parenta78a4eb45067d42a5af635715bc94d048c04bcb5 (diff)
parent0989bd84dfd4b97a66b1777c6138957f70e02134 (diff)
Merge branch 'gstreamer1' of https://github.com/MikePetullo/packages
Diffstat (limited to 'libs')
-rw-r--r--libs/liboil/Makefile12
-rw-r--r--libs/libsoup/Makefile75
2 files changed, 83 insertions, 4 deletions
diff --git a/libs/liboil/Makefile b/libs/liboil/Makefile
index d444f69d4..ce844e2d6 100644
--- a/libs/liboil/Makefile
+++ b/libs/liboil/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,16 +9,20 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=liboil
PKG_VERSION:=0.3.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://liboil.freedesktop.org/download/
PKG_MD5SUM:=47dc734f82faeb2964d97771cfd2e701
+PKG_LICENSE:=FREE
+PKG_LICENSE_FILE:=COPYING
+
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
define Package/liboil
SECTION:=libs
@@ -26,7 +30,7 @@ define Package/liboil
TITLE:=simple functions optimized for various CPUs
URL:=http://liboil.freedesktop.org/wiki/
MAINTAINER:=W. Michael Petullo <mike@flyn.org>
- DEPENDS:=+librt
+ DEPENDS:=+librt $(ICONV_DEPENDS) $(INTL_DEPENDS)
endef
define Package/liboil/description
@@ -42,7 +46,7 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) $(if $(ICONV_FULL),-liconv) $(if $(INTL_FULL),-lintl)
# XXX: VFP_CFLAGS is set to '-mfpu=vfp' on arm by configure, but that breaks
# final linking stages, so override it until we find why
diff --git a/libs/libsoup/Makefile b/libs/libsoup/Makefile
new file mode 100644
index 000000000..feb6264c0
--- /dev/null
+++ b/libs/libsoup/Makefile
@@ -0,0 +1,75 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libsoup
+PKG_VERSION:=2.38.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNOME/$(PKG_NAME)/2.38
+PKG_MD5SUM:=d13fb4968acea24c26b83268a308f580
+
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILE:=COPYING
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+TARGET_LDFLAGS+=\
+ -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(if $(ICONV_FULL),-liconv)
+
+define Package/libsoup
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=libsoup
+ URL:=http://live.gnome.org/LibSoup
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+ DEPENDS:=+glib2 +libxml2 +libgnutls $(ICONV_DEPENDS) $(INTL_DEPENDS)
+endef
+
+define Build/Configure
+ $(call Build/Configure/Default, \
+ --enable-ssl \
+ --disable-glibtest \
+ --without-apache-httpd \
+ --without-gnome \
+ )
+endef
+
+define package/libsoup/decription
+Libsoup is an HTTP library implementation in C
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/libsoup-2.4/libsoup}
+
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libsoup-2.4.{so*,la,a} \
+ $(1)/usr/lib/
+
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
+ $(1)/usr/lib/pkgconfig/
+
+ $(INSTALL_DATA) \
+ $(PKG_INSTALL_DIR)/usr/include/libsoup-2.4/libsoup/*.h \
+ $(1)/usr/include/libsoup-2.4/libsoup/
+endef
+
+define Package/libsoup/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libsoup-2.4.so* \
+ $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libsoup))