aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2021-03-08 14:48:07 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2021-03-08 14:48:41 +0100
commitd4ead62706cac0d1b5a9d4bdcc3def6a9d038111 (patch)
tree3376f4319793da41590a7bc6f880f5d402c4e508 /libs
parent7bc897eb94c09c8fe2472091709fab7446b37976 (diff)
redis: update to version 6.2.1
Changes: -remove zmalloc patch which is part of release Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
Diffstat (limited to 'libs')
-rw-r--r--libs/redis/Makefile4
-rw-r--r--libs/redis/patches/030-fix-size_t-zmalloc.patch43
2 files changed, 2 insertions, 45 deletions
diff --git a/libs/redis/Makefile b/libs/redis/Makefile
index 418758872..4ed494c44 100644
--- a/libs/redis/Makefile
+++ b/libs/redis/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=redis
-PKG_VERSION:=6.2.0
+PKG_VERSION:=6.2.1
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://download.redis.io/releases/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=67d624c25d962bd68aff8812a135df85bad07556b8825f3bcd5b522a9932dbca
+PKG_HASH:=cd222505012cce20b25682fca931ec93bd21ae92cb4abfe742cf7b76aa907520
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
PKG_LICENSE:=BSD-3-Clause
diff --git a/libs/redis/patches/030-fix-size_t-zmalloc.patch b/libs/redis/patches/030-fix-size_t-zmalloc.patch
deleted file mode 100644
index a0bfacb8f..000000000
--- a/libs/redis/patches/030-fix-size_t-zmalloc.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From dd885780d67f18f356a5652ab6d4f947ee035305 Mon Sep 17 00:00:00 2001
-From: Yossi Gottlieb <yossigo@gmail.com>
-Date: Tue, 23 Feb 2021 17:08:49 +0200
-Subject: [PATCH] Fix compile errors with no HAVE_MALLOC_SIZE. (#8533)
-
-Also adds a new daily CI test, relying on the fact that we don't use malloc_size() on alpine libmusl.
-
-Fixes #8531
----
- .github/workflows/daily.yml | 22 +++++++++++++++++++++-
- src/zmalloc.c | 7 ++-----
- 2 files changed, 23 insertions(+), 6 deletions(-)
-
---- a/src/zmalloc.c
-+++ b/src/zmalloc.c
-@@ -32,6 +32,7 @@
- #include <stdlib.h>
- #include <stdint.h>
- #include <unistd.h>
-+#include <assert.h>
-
- /* This function provide us access to the original libc free(). This is useful
- * for instance to free results obtained by backtrace_symbols(). We need
-@@ -49,18 +50,14 @@ void zlibc_free(void *ptr) {
-
- #ifdef HAVE_MALLOC_SIZE
- #define PREFIX_SIZE (0)
-+#define ASSERT_NO_SIZE_OVERFLOW(sz)
- #else
- #if defined(__sun) || defined(__sparc) || defined(__sparc__)
- #define PREFIX_SIZE (sizeof(long long))
- #else
- #define PREFIX_SIZE (sizeof(size_t))
- #endif
--#endif
--
--#if PREFIX_SIZE > 0
- #define ASSERT_NO_SIZE_OVERFLOW(sz) assert((sz) + PREFIX_SIZE > (sz))
--#else
--#define ASSERT_NO_SIZE_OVERFLOW(sz)
- #endif
-
- /* Explicitly override malloc/free etc when using tcmalloc. */