aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2024-04-07 20:48:32 -0700
committerRosen Penev <rosenp@gmail.com>2024-04-08 01:30:31 -0700
commitd24229e4415b4a5c4fb7784d20c8748c9a9ebf4b (patch)
tree55676b47b52dc5c41be0c4c849ea6a0a0731b584 /libs
parent9f78055f94d732ad5a3fbb07b5c36f0859bc1215 (diff)
protobuf: don't use shared libraries for host
Avoids needing to handle rpath. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/protobuf/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/libs/protobuf/Makefile b/libs/protobuf/Makefile
index de6aa5a40..7e60e8498 100644
--- a/libs/protobuf/Makefile
+++ b/libs/protobuf/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=protobuf
PKG_VERSION:=3.17.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-cpp-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/google/protobuf/releases/download/v$(PKG_VERSION)
@@ -67,10 +67,8 @@ endef
CMAKE_HOST_OPTIONS += \
-Dprotobuf_BUILD_PROTOC_BINARIES=ON \
-Dprotobuf_BUILD_TESTS=OFF \
- -DBUILD_SHARED_LIBS=ON \
- -DCMAKE_SKIP_RPATH=OFF \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOSTPKG}/lib"
+ -DBUILD_SHARED_LIBS=OFF \
+ -DCMAKE_INSTALL_LIBDIR=lib
CMAKE_OPTIONS += \
-Dprotobuf_BUILD_PROTOC_BINARIES=ON \
@@ -78,7 +76,7 @@ CMAKE_OPTIONS += \
-Dprotobuf_WITH_ZLIB=ON \
-DBUILD_SHARED_LIBS=ON
-TARGET_LDFLAGS += -latomic $(if $(CONFIG_USE_GLIBC),-lm)
+TARGET_LDFLAGS += -latomic
define Build/InstallDev
$(call Build/InstallDev/cmake,$(1))