aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-12 12:13:20 -0700
committerGitHub <noreply@github.com>2019-04-12 12:13:20 -0700
commitc36e8c6ea2d5ac47491c9edc16c749b3b6d0fce1 (patch)
treee37f241d81f296ae330151b19906133f60d33aed /libs
parent045da6f2d48e9d8577d9cde79641840377c316bd (diff)
parent655e8361e73d81b4a7d18102ef4167d0ff44cd8e (diff)
Merge pull request #7951 from micmac1/hiredis-pkg-config
hiredis: fix pkg-config file
Diffstat (limited to 'libs')
-rw-r--r--libs/hiredis/Makefile2
-rw-r--r--libs/hiredis/patches/010-fix_pkconfig_file.patch34
2 files changed, 35 insertions, 1 deletions
diff --git a/libs/hiredis/Makefile b/libs/hiredis/Makefile
index 090339278..1ec13921b 100644
--- a/libs/hiredis/Makefile
+++ b/libs/hiredis/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hiredis
PKG_VERSION:=0.14.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/redis/hiredis/tar.gz/v$(PKG_VERSION)?
diff --git a/libs/hiredis/patches/010-fix_pkconfig_file.patch b/libs/hiredis/patches/010-fix_pkconfig_file.patch
new file mode 100644
index 000000000..955777627
--- /dev/null
+++ b/libs/hiredis/patches/010-fix_pkconfig_file.patch
@@ -0,0 +1,34 @@
+commit f96d9f9d2e3ba39352035e6ac26463243484d404
+Author: Sebastian Kemper <sebastian_ml@gmx.net>
+Date: Sun Jan 13 19:25:52 2019 +0100
+
+ Setup .pc file to allow use for cross-compiling
+
+ The Makefile is currently creating the pkg-config file using static lib
+ and include dir statements. Change that so that projects that
+ cross-compile hiredis can use pkg-config to setup other programs
+ depending on it.
+
+ Note: these projects (like OpenWrt) call pkg-config with arguments to
+ overwrite some variables in the .pc file, namely:
+
+ --define-variable=prefix=<...>
+ --define-variable=exec_prefix=<...>
+
+ Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
+
+diff --git a/Makefile b/Makefile
+index 07b8a83..14d21de 100644
+--- a/Makefile
++++ b/Makefile
+@@ -166,8 +166,8 @@ $(PKGCONFNAME): hiredis.h
+ @echo "Generating $@ for pkgconfig..."
+ @echo prefix=$(PREFIX) > $@
+ @echo exec_prefix=\$${prefix} >> $@
+- @echo libdir=$(PREFIX)/$(LIBRARY_PATH) >> $@
+- @echo includedir=$(PREFIX)/$(INCLUDE_PATH) >> $@
++ @echo libdir=\$${exec_prefix}/$(LIBRARY_PATH) >> $@
++ @echo includedir=\$${prefix}/$(INCLUDE_PATH) >> $@
+ @echo >> $@
+ @echo Name: hiredis >> $@
+ @echo Description: Minimalistic C client library for Redis. >> $@