aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2019-10-28 19:36:15 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2019-10-28 19:36:18 +0100
commitb16766c0b7ebefb79c9548daacee3e996c95e7a0 (patch)
treea7fda677e480ed875e86ee1518b330946266cf78 /libs
parent0cc57a1e9a31d17fcb03b8ec65d030a31a4086e6 (diff)
libqmi: fix compile on build bots
On the OpenWrt build bots the compile currently fails: cc1: error: /builder/shared-workdir/build/sdk/staging_dir/target-arm_cortex-a5+vfpv4_musl_eabi/include: No such file or directory [-Werror=missing-include-dirs] cc1: all warnings being treated as errors (Or rather, it _would_ fail like this if libmbim compiled successfully.) The directory in question gets added to TARGET_CPPFLAGS by rules.mk. Nothing usually gets installed to that directory, so unsurprisingly it may not exist on the build bots. On first glance this problem cannot be reproduced. But once autoreconf is called this becomes possible. If called without "--enable-more-warnings", configure adds -Werror to the flags. This commit adds "--enable-more-warnings=yes" to the build. This way the extra warnings are kept in place, but they aren't turned into errors no more. "PKG_FIXUP:=autoreconf" is also added so that it's easier to forecast build failures on the build bots when preparing future pull request. Last but not least "--disable-silent-rules" is added, because more output is usually welcome for debugging, be it on the build bots or at home/the office. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs')
-rw-r--r--libs/libqmi/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/libs/libqmi/Makefile b/libs/libqmi/Makefile
index 5445a9f5d..04d9628d7 100644
--- a/libs/libqmi/Makefile
+++ b/libs/libqmi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libqmi
PKG_VERSION:=1.24.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.freedesktop.org/software/libqmi
@@ -20,6 +20,8 @@ PKG_MAINTAINER:=Nicholas Smith <nicholas.smith@telcoantennas.com.au>
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PKG_FIXUP:=autoreconf
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -57,8 +59,10 @@ CONFIGURE_ARGS += \
--disable-gtk-doc \
--disable-gtk-doc-html \
--disable-gtk-doc-pdf \
- --enable-mbim-qmux \
+ --disable-silent-rules \
--enable-firmware-update \
+ --enable-mbim-qmux \
+ --enable-more-warnings=yes \
--without-udev \
--without-udev-base-dir