aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorBangLang Huang <banglang.huang@foxmail.com>2017-02-21 14:49:50 +0800
committerBangLang Huang <banglang.huang@foxmail.com>2017-02-21 14:49:50 +0800
commitaf58a42344485aa79a0832e7a0f00bdc06841109 (patch)
treeb02f4deeb07be4f352457c4c1c346d5e1dedd624 /libs
parent327aab9a13590ac42fe2d40c48d61f1390bce466 (diff)
libndpi: add new package
nDPI is an open source LGPLv3 library for deep-packet inspection. Based on OpenDPI it includes ntop extensions. It had been tried to push the source code into the OpenDPI source tree but nobody answered emails so the ntop team had decided to create their own source tree. github site: https://github.com/ntop/nDPI official site: http://www.ntop.org/ Signed-off-by: BangLang Huang <banglang.huang@foxmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libndpi/Makefile74
1 files changed, 74 insertions, 0 deletions
diff --git a/libs/libndpi/Makefile b/libs/libndpi/Makefile
new file mode 100644
index 000000000..bff0b77e0
--- /dev/null
+++ b/libs/libndpi/Makefile
@@ -0,0 +1,74 @@
+#
+# Copyright (C) 2017 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libndpi
+PKG_VERSION:=1.8
+PKG_RELEASE:=1
+PKG_MAINTAINER:=Banglang Huang <banglang.huang@foxmail.com>
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/ntop/nDPI.git
+PKG_SOURCE_VERSION:=6450ae256cfd7a6006d39df4a29de32f2f6fb7eb
+
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_LICENSE:=LGPLv3
+
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libndpi
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Library for deep-packet inspection
+ URL:=https://github.com/ntop/nDPI
+ DEPENDS:=+libpcap +libjson-c
+endef
+
+define Package/libndpi/description
+ nDPI is an open source LGPLv3 library for deep-packet inspection.
+ Based on OpenDPI it includes ntop extensions.
+endef
+
+define Build/Configure
+ ( cd $(PKG_BUILD_DIR); ./autogen.sh )
+ $(call Build/Configure/Default)
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/include/libndpi-1.8.0/libndpi \
+ $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libndpi.so* \
+ $(1)/usr/lib/
+
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libndpi.pc \
+ $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libndpi/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libndpi.so* \
+ $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/bin/ndpiReader \
+ $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,libndpi))