aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <morikw2@gmail.com>2021-11-02 09:14:00 +0900
committerHirokazu MORIKAWA <morikw2@gmail.com>2021-11-02 09:14:00 +0900
commitaa5a0ccb7d91eb39634dce3caa2e1b4f7d0c361b (patch)
tree795e2f8f5c73f05a0788f2509c72d9e1515f7ddc /libs
parent63e277114030e6abfafc8d095279a8c6f91a1e40 (diff)
icu: bump to 70.1
ICU 70 released. It updates to Unicode 14, including new characters, scripts, emoji, and corresponding API constants. ICU 70 adds support for emoji properties of strings. It also updates to CLDR 40 locale data with many additions and corrections. ICU 70 also includes many other bug fixes and enhancements, especially for measurement unit formatting, and it can now be built and used with C++20 compilers. This change will require minor modifications in php7 and php8. Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/icu/Makefile4
-rw-r--r--libs/icu/patches/010-max_align_t.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/libs/icu/Makefile b/libs/icu/Makefile
index ad4f5bd71..0289fca97 100644
--- a/libs/icu/Makefile
+++ b/libs/icu/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=icu4c
-MAJOR_VERSION:=69
+MAJOR_VERSION:=70
MINOR_VERSION:=1
PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
-PKG_HASH:=4cba7b7acd1d3c42c44bb0c14be6637098c7faf2b330ce876bc5f3b915d09745
+PKG_HASH:=8d205428c17bf13bb535300669ed28b338a157b1c01ae66d31d0d3e2d47c3fd5
PKG_LICENSE:=ICU
PKG_LICENSE_FILES:=LICENSE
diff --git a/libs/icu/patches/010-max_align_t.patch b/libs/icu/patches/010-max_align_t.patch
index 0a139b124..6ccb1d629 100644
--- a/libs/icu/patches/010-max_align_t.patch
+++ b/libs/icu/patches/010-max_align_t.patch
@@ -49,7 +49,7 @@
if (ut == NULL) {
--- a/tools/toolutil/toolutil.cpp
+++ b/tools/toolutil/toolutil.cpp
-@@ -242,7 +242,7 @@ struct UToolMemory {
+@@ -266,7 +266,7 @@ struct UToolMemory {
char name[64];
int32_t capacity, maxCapacity, size, idx;
void *array;