aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-02 14:43:23 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-04 19:11:25 -0700
commita89a876de9ceac06ae05ad4fddeca7c4abef6460 (patch)
treea5f18b382e7178b1360ca25f49ce65d341167c66 /libs
parent7f620401afb185abac26e5e186150f5b53ea6ed0 (diff)
ldns: fix compilation without deprecated APIs
Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/ldns/Makefile2
-rw-r--r--libs/ldns/patches/001-compile-for-darwin.patch2
-rw-r--r--libs/ldns/patches/030-signzone.patch18
3 files changed, 20 insertions, 2 deletions
diff --git a/libs/ldns/Makefile b/libs/ldns/Makefile
index ca84b588f..c53567d93 100644
--- a/libs/ldns/Makefile
+++ b/libs/ldns/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ldns
PKG_VERSION:=1.7.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.nlnetlabs.nl/downloads/ldns
diff --git a/libs/ldns/patches/001-compile-for-darwin.patch b/libs/ldns/patches/001-compile-for-darwin.patch
index 1108c668c..3449d8609 100644
--- a/libs/ldns/patches/001-compile-for-darwin.patch
+++ b/libs/ldns/patches/001-compile-for-darwin.patch
@@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -881,7 +881,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
+@@ -861,7 +861,7 @@ AC_ARG_WITH(xcode-sdk, AC_HELP_STRING([--with-xcode-sdk],
[],[with_xcode_sdk="yes"])
if test "x_$with_xcode_sdk" != "x_no" ; then
# check OSX deployment target, if needed
diff --git a/libs/ldns/patches/030-signzone.patch b/libs/ldns/patches/030-signzone.patch
new file mode 100644
index 000000000..f001ab857
--- /dev/null
+++ b/libs/ldns/patches/030-signzone.patch
@@ -0,0 +1,18 @@
+--- a/examples/ldns-signzone.c
++++ b/examples/ldns-signzone.c
+@@ -535,6 +535,7 @@ init_openssl_engine ( const char * const id )
+ static void
+ shutdown_openssl ( ENGINE * const e )
+ {
++#if OPENSSL_VERSION_NUMBER < 0x10100000 || defined(HAVE_LIBRESSL)
+ if ( e != NULL ) {
+ ENGINE_free ( e );
+ ENGINE_cleanup ();
+@@ -544,6 +545,7 @@ shutdown_openssl ( ENGINE * const e )
+ EVP_cleanup ();
+ CRYPTO_cleanup_all_ex_data ();
+ ERR_free_strings ();
++#endif
+ }
+ #endif
+