aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-16 18:28:11 -0700
committerRosen Penev <rosenp@gmail.com>2020-05-16 18:29:08 -0700
commita80658beeb186309c92e3c2d0438a8586facd4b5 (patch)
treeddcae33fbab28b990028ac4bd9e8baaaab3608fc /libs
parentdad8672037a5262237d24e2b74fedf614e137065 (diff)
libwebp: fix compilation under ARM without NEON
The CMake logic seems broken. Luckily it's easy to work around. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libwebp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/libs/libwebp/Makefile b/libs/libwebp/Makefile
index bb0ce974b..34510345b 100644
--- a/libs/libwebp/Makefile
+++ b/libs/libwebp/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libwebp
PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://storage.googleapis.com/downloads.webmproject.org/releases/webp
@@ -41,6 +41,12 @@ CMAKE_OPTIONS += \
-DWEBP_BUILD_WEBPMUX=OFF \
-DWEBP_BUILD_EXTRAS=OFF
+ifneq ($(findstring arm,$(CONFIG_ARCH)),)
+ifeq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
+CMAKE_OPTIONS += -DWEBP_ENABLE_SIMD=OFF
+endif
+endif
+
TARGET_CFLAGS += -flto
define Package/libwebp/install