aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorSebastian Kemper <sebastian_ml@gmx.net>2018-02-24 12:02:48 +0100
committerSebastian Kemper <sebastian_ml@gmx.net>2018-02-24 12:02:49 +0100
commita57ffe6c639c482d49984bd587a13c947599869a (patch)
treee33d6451621800a703591e12a21b18eb656c95d5 /libs
parent8bd3bd86ada61be5edcf89f9e1d51402c5688e79 (diff)
libxslt: remove $(FPIC) from TARGET_CFLAGS
libxslt already makes sure that the compiler emits position-independent code. Adding $(FPIC) makes no difference. In addition the libxslt build system puts its own flag behind the CFLAGS, overriding whatever was set before. Also with $(FPIC) in CFLAGS even the libxslt utils get compiled with PIC, which us undesirable. Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
Diffstat (limited to 'libs')
-rw-r--r--libs/libxslt/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/libs/libxslt/Makefile b/libs/libxslt/Makefile
index 9f276d3fd..4de059724 100644
--- a/libs/libxslt/Makefile
+++ b/libs/libxslt/Makefile
@@ -73,8 +73,6 @@ CONFIGURE_ARGS+= \
--without-mem-debug \
--without-debugger \
-TARGET_CFLAGS += $(FPIC)
-
define Build/InstallDev/Xslt
$(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
$(1)/usr/include/libexslt $(1)/usr/lib \