aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authortripolar <tripolar@users.noreply.github.com>2020-04-19 11:40:04 +0200
committerGitHub <noreply@github.com>2020-04-19 11:40:04 +0200
commita3c62bf8f0e96cb9a6f73a0dc9370e5c880b8750 (patch)
treec0858e8775c611464cff98f27bb40ad9066d4cdb /libs
parent08b643d12111beb6a89120ab92d98f1373a712dd (diff)
parent22e823147197847b975f6f8589731a9395434ca5 (diff)
Merge pull request #10601 from neheb/alsa
ALSA update - 1.2.2
Diffstat (limited to 'libs')
-rw-r--r--libs/alsa-lib/Makefile36
-rw-r--r--libs/alsa-lib/patches/100-link_fix.patch2
-rw-r--r--libs/alsa-lib/patches/200-usleep.patch34
3 files changed, 66 insertions, 6 deletions
diff --git a/libs/alsa-lib/Makefile b/libs/alsa-lib/Makefile
index 4af984ec4..82c4e2b0f 100644
--- a/libs/alsa-lib/Makefile
+++ b/libs/alsa-lib/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
-PKG_VERSION:=1.1.9
+PKG_VERSION:=1.2.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
http://distfiles.gentoo.org/distfiles/
-PKG_HASH:=488373aef5396682f3a411a6d064ae0ad196b9c96269d0bb912fbdeec94b994b
+PKG_HASH:=d8e853d8805574777bbe40937812ad1419c9ea7210e176f0def3e6ed255ab3ec
PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
Peter Wagner <tripolar@gmx.at>
@@ -32,7 +32,7 @@ define Package/alsa-lib
TITLE:=ALSA (Advanced Linux Sound Architecture) library
URL:=http://www.alsa-project.org/
DEPENDS:=@AUDIO_SUPPORT +kmod-sound-core +libpthread +librt
- LICENSE:=LGPLv2.1-or-later
+ LICENSE:=LGPL-2.1-or-later
LICENSE_FILES:=COPYING
endef
@@ -41,6 +41,20 @@ define Package/alsa-lib/description
You must have enabled the ALSA support in the kernel.
endef
+define Package/aserver
+ SECTION:=sound
+ CATEGORY:=Sound
+ TITLE:=ALSA (Advanced Linux Sound Architecture) server
+ URL:=http://www.alsa-project.org/
+ DEPENDS:=+alsa-lib
+ LICENSE:=GPL-2.0-or-later
+ LICENSE_FILES:=aserver/COPYING
+endef
+
+define Package/aserver/description
+ This is the aserver application for ALSA.
+endef
+
define Package/alsa-lib/conffiles
/etc/asound.conf
endef
@@ -51,8 +65,8 @@ CONFIGURE_ARGS+= \
--disable-python \
--disable-debug \
--without-debug \
- $(SOFT_FLOAT_CONFIG_OPTION) \
- --with-versioned=no
+ --without-versioned \
+ $(SOFT_FLOAT_CONFIG_OPTION)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
@@ -64,6 +78,9 @@ define Build/InstallDev
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libasound.{la,so*} \
$(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libatopology.{la,so*} \
+ $(1)/usr/lib/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc \
$(1)/usr/lib/pkgconfig/
@@ -79,6 +96,9 @@ define Package/alsa-lib/install
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libasound.so.* \
$(1)/usr/lib/
+ $(CP) \
+ $(PKG_INSTALL_DIR)/usr/lib/libatopology.so.* \
+ $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/share/alsa/{cards,pcm}
$(INSTALL_DATA) \
@@ -92,4 +112,10 @@ define Package/alsa-lib/install
$(1)/usr/share/alsa/cards/
endef
+define Package/aserver/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aserver $(1)/usr/bin
+endef
+
$(eval $(call BuildPackage,alsa-lib))
+$(eval $(call BuildPackage,aserver))
diff --git a/libs/alsa-lib/patches/100-link_fix.patch b/libs/alsa-lib/patches/100-link_fix.patch
index 5d1117811..9a3258c72 100644
--- a/libs/alsa-lib/patches/100-link_fix.patch
+++ b/libs/alsa-lib/patches/100-link_fix.patch
@@ -1,6 +1,6 @@
--- a/src/Makefile.in
+++ b/src/Makefile.in
-@@ -493,7 +493,7 @@ clean-libLTLIBRARIES:
+@@ -490,7 +490,7 @@ clean-libLTLIBRARIES:
}
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES) $(EXTRA_libasound_la_DEPENDENCIES)
diff --git a/libs/alsa-lib/patches/200-usleep.patch b/libs/alsa-lib/patches/200-usleep.patch
new file mode 100644
index 000000000..86badc202
--- /dev/null
+++ b/libs/alsa-lib/patches/200-usleep.patch
@@ -0,0 +1,34 @@
+--- a/src/pcm/pcm_shm.c
++++ b/src/pcm/pcm_shm.c
+@@ -45,6 +45,14 @@
+ #include <netdb.h>
+ #include "aserver.h"
+
++#if _POSIX_C_SOURCE >= 200809L
++#define usleep(a) \
++ do { \
++ const struct timespec req = {0, a * 1000}; \
++ nanosleep(&req, NULL); \
++ } while(0)
++#endif
++
+ #ifndef PIC
+ /* entry for static linking */
+ const char *_snd_module_pcm_shm = "";
+--- a/src/ucm/ucm_local.h
++++ b/src/ucm/ucm_local.h
+@@ -53,6 +53,14 @@
+ #define SEQUENCE_ELEMENT_TYPE_CSET_TLV 6
+ #define SEQUENCE_ELEMENT_TYPE_CMPT_SEQ 7
+
++#if _POSIX_C_SOURCE >= 200809L
++#define usleep(a) \
++ do { \
++ const struct timespec req = {0, a * 1000}; \
++ nanosleep(&req, NULL); \
++ } while(0)
++#endif
++
+ struct ucm_value {
+ struct list_head list;
+ char *name;