aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-08 00:55:32 -0800
committerGitHub <noreply@github.com>2020-12-08 00:55:32 -0800
commita0b58ea57f2cb24e538c6ce21a05b087e13428cb (patch)
treed3dac3f12d603b905d7c3b259c6a8add9ddf085f /libs
parent46bb62b1afdd03ade3198ac5a8e38b28cbec1486 (diff)
parent865031590fccfb6c533cfffba82a90f07a133291 (diff)
Merge pull request #14166 from neheb/neonn
neon: install neon-config to host path
Diffstat (limited to 'libs')
-rw-r--r--libs/neon/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/libs/neon/Makefile b/libs/neon/Makefile
index 328eb8bcc..f3aaa38d3 100644
--- a/libs/neon/Makefile
+++ b/libs/neon/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=neon
PKG_VERSION:=0.31.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://notroj.github.io/neon
@@ -65,8 +65,9 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libneon.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/neon.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's,-I$$$${includedir}/,-I$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/neon-config
- $(SED) 's,-L$$$${libdir},,g' $(1)/usr/bin/neon-config
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/neon-config
+ $(INSTALL_DIR) $(2)/bin
+ $(LN) ../../usr/bin/neon-config $(2)/bin/neon-config
endef
define Package/libneon/install