aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-27 18:49:06 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-05-27 18:49:06 +0200
commit9e2788c96bdb2900b140d69528d45e4e12a15f8a (patch)
treee849448a7c0fe972a4717a46fd1719f36c426c69 /libs
parent11a3e4c515d9f8b293401e1931a3dabddbcc7589 (diff)
parent10e7191a6f03f75e9a08b5eb493927e60078156b (diff)
Merge pull request #1181 from ryzhovau/ipv6_opt
Optional IPv6 support
Diffstat (limited to 'libs')
-rw-r--r--libs/apr/Makefile4
-rw-r--r--libs/libtorrent/Makefile5
2 files changed, 5 insertions, 4 deletions
diff --git a/libs/apr/Makefile b/libs/apr/Makefile
index 924db85b4..d61d31f9e 100644
--- a/libs/apr/Makefile
+++ b/libs/apr/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=apr
PKG_VERSION:=1.5.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://mirrors.ibiblio.org/apache/apr/
@@ -38,7 +38,7 @@ TARGET_CPPFLAGS += -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
CONFIGURE_ARGS += \
--with-devrandom=/dev/urandom \
--disable-dso \
- --enable-ipv6
+ $(call autoconf_bool,CONFIG_IPV6,ipv6)
# XXX: ac_cv_sizeof_struct_iovec=1 is just to trick configure
CONFIGURE_VARS += \
diff --git a/libs/libtorrent/Makefile b/libs/libtorrent/Makefile
index f6673acaa..2001235a9 100644
--- a/libs/libtorrent/Makefile
+++ b/libs/libtorrent/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libtorrent
-PKG_VERSION:=0.13.4-git-0
+PKG_VERSION:=0.13.4-git-1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
@@ -49,7 +49,8 @@ CONFIGURE_ARGS+= \
--disable-debug \
--enable-openssl \
--disable-instrumentation \
- --with-zlib=$(STAGING_DIR)/usr
+ --with-zlib=$(STAGING_DIR)/usr \
+ $(call autoconf_bool,CONFIG_IPV6,ipv6)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include