aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-08-13 23:52:41 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-08-13 23:52:41 +0200
commit9cfcbeeeac85e67a64527ee3fac890212b5fccbb (patch)
treeac1358487864f524d01e6d960902535ea9d7eb77 /libs
parent0bb0084691706914e57db553cb1a1be2d11fbd4e (diff)
parent714a408a6e872d7e478ed297c73e3812971d22df (diff)
Merge pull request #1655 from dangowrt/update-postgresql
update postgresql
Diffstat (limited to 'libs')
-rw-r--r--libs/postgresql/Makefile49
-rw-r--r--libs/postgresql/files/postgresql.init124
-rw-r--r--libs/postgresql/patches/001-configure_fixes.patch11
-rw-r--r--libs/postgresql/patches/200-ranlib.patch4
-rw-r--r--libs/postgresql/patches/800-busybox-default-pager.patch2
5 files changed, 77 insertions, 113 deletions
diff --git a/libs/postgresql/Makefile b/libs/postgresql/Makefile
index e3b5ceebf..33cb010ab 100644
--- a/libs/postgresql/Makefile
+++ b/libs/postgresql/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=postgresql
-PKG_VERSION:=9.0.17
+PKG_VERSION:=9.4.4
PKG_RELEASE:=1
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
PKG_LICENSE:=PostgreSQL
@@ -18,10 +18,11 @@ PKG_SOURCE_URL:=\
http://ftp9.us.postgresql.org/pub/mirrors/postgresql/source/v$(PKG_VERSION) \
http://ftp.be.postgresql.org/postgresql/source/v$(PKG_VERSION) \
ftp://ftp-archives.postgresql.org/pub/source/v$(PKG_VERSION)
-PKG_MD5SUM:=46bf3ef3761c091fb0d2e25012c1709e
+PKG_MD5SUM:=1fe952c44ed26d7e6a335cf991a9c1c6
PKG_BUILD_PARALLEL:=1
PKG_USE_MIPS16:=0
PKG_FIXUP:=autoreconf
+PKG_MACRO_PATHS:=config
include $(INCLUDE_DIR)/package.mk
@@ -58,6 +59,7 @@ define Package/pgsql-server
TITLE:=PostgreSQL databases Server
URL:=http://www.postgresql.org/
SUBMENU:=database
+ USERID:=postgres=5432:postgres=5432
endef
define Package/pgsql-server/description
@@ -85,17 +87,15 @@ define Build/Configure
--enable-static \
--disable-integer-datetimes \
--disable-rpath \
- --without-java \
- --without-krb4 \
- --without-krb5 \
+ --without-bonjour \
+ --without-gssapi \
+ --without-ldap \
--without-openssl \
--without-pam \
--without-perl \
--without-python \
--without-readline \
- --without-rendezvous \
--without-tcl \
- --without-tk \
--with-zlib="yes" \
--enable-depend \
--with-system-timezone=/tmp \
@@ -141,16 +141,14 @@ define Build/Configure
--enable-static \
--disable-integer-datetimes \
--disable-rpath \
- --without-java \
- --without-krb4 \
- --without-krb5 \
+ --without-bonjour \
+ --without-gssapi \
+ --without-ldap \
--without-openssl \
--without-pam \
--without-perl \
--without-python \
- --without-rendezvous \
--without-tcl \
- --without-tk \
--with-zlib="yes" \
--enable-depend \
$(if $(CONFIG_TARGET_avr32),--disable-spinlocks) \
@@ -207,32 +205,6 @@ define Package/pgsql-server/conffiles
/etc/config/postgresql
endef
-define Package/pgsql-server/postinst
-#!/bin/sh
-grep -q '^postgres:' /etc/passwd && exit 0
-group=$$(grep '^postgres:' /etc/group | cut -f3 -d:)
-if [ -z "$${group}" ] ; then
- group=1000
- tst=$$(cat /etc/group | grep ":$${group}:")
- while [ -n "$${tst}" ] ; do
- group=$$(($${group}+1))
- tst=$$(cat /etc/group | grep ":$${group}:")
- done
- echo "postgres:x:$${group}:" >>/etc/group
-fi
-
-user=$$(cat /etc/passwd | grep "^postgres:")
-if [ -z "$${user}" ] ; then
- num="$${group}"
- tst=$$(cat /etc/passwd | grep ":.*:$${num}:")
- while [ -n "$${tst}" ] ; do
- num=$$(($${num}+1))
- tst=$$(cat /etc/passwd | grep ":.*:$${num}:")
- done
- echo "postgres:*:$${num}:$${group}:PostgreSQL administrator:/tmp:/bin/ash" >>/etc/passwd
-fi
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bin/pg_config/pg_config.host $(1)/usr/bin/pg_config
@@ -242,6 +214,7 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_manual.h $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/pg_config_ext.h $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/postgresql $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpq.{a,so*} $(1)/usr/lib/
diff --git a/libs/postgresql/files/postgresql.init b/libs/postgresql/files/postgresql.init
index 1e1c52f95..458e8c00f 100644
--- a/libs/postgresql/files/postgresql.init
+++ b/libs/postgresql/files/postgresql.init
@@ -1,93 +1,73 @@
#!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
START=50
-EXTRA_COMMANDS="status reload"
+PROG=/usr/bin/postmaster
-config_load "postgresql"
-config_get pgdata config PGDATA
-config_get pguser config PGUSER
-config_get pgctl config PG_CTL
-config_get pglog config PGLOG
+USE_PROCD=1
-start() {
- if [ ! -e /usr/bin/su ]; then
- echo "The su command is requred to run postgres"
- exit 1
- fi
+EXTRA_COMMANDS="status"
+EXTRA_HELP=" status Show current status of the PostgreSQL server"
- if [ ! -d ${pgdata} ]; then
- echo "Create the data directory (${pgdata}) and try again"
- exit 1
- fi
+fix_hosts() {
+ # make sure localhost (without a dot) is in /etc/hosts
+ grep -q 'localhost$' /etc/hosts || echo '127.0.0.1 localhost' >> /etc/hosts
+}
- echo "starting postgres..."
- # make sure localhost (without a dot) is in /etc/hosts
- grep -q 'localhost$' /etc/hosts || echo '127.0.0.1 localhost' >> /etc/hosts
+fix_perms() {
+ # for whatever reason, /dev/null gets wrong perms
+ chmod a+w /dev/null
+}
- # for whatever reason, /dev/null gets wrong perms
- chmod a+w /dev/null
+cleanup() {
+ if [ -f "$1/postmaster.pid" ]; then
+ rm "$1/postmaster.pid"
+ fi
+}
- if [ -f ${pgdata}/postmaster.pid ]; then
- rm ${pgdata}/postmaster.pid
- fi
+start_service() {
+ config_load "postgresql"
+ config_get pgdata config PGDATA
+ config_get pguser config PGUSER
+ config_get pgctl config PG_CTL
+ config_get pgopts config PGOPTS
- config_get pgopts config PGOPTS
- if [ -n "${pgopts}" ]; then
- pgopts="-o ${pgopts}"
- fi
- /usr/bin/su ${pguser} -c "/usr/bin/postmaster -D '${pgdata}' &" >> ${pglog} 2>&1
+ user_exists postgres 5432 || user_add postgres 5432
+ group_exists postgres 5432 || group_add postgres 5432
- while :
- do
- cnt=$((${cnt} + 1))
- if [ -f "${pgdata}/postmaster.pid" ]; then
- ret=0
- break
- fi
+ if [ ! -d "${pgdata}" ]; then
+ echo "Create the data directory (${pgdata}) and try again"
+ return 1
+ fi
- if [ ${cnt} -eq 30 ]; then
- echo "Postgres failed to start. See ${pglog} for details"
- ret=1
- break
- fi
- sleep 1
- done
+ fix_perms
+ fix_hosts
- echo "ok"
- return ${ret}
-}
+ procd_open_instance
-stop() {
- echo "stopping postgres..."
- /usr/bin/su ${pguser} -c "${pgctl} stop -D '${pgdata}' -s -m fast"
- ret=$?
- if [ -f ${pgdata}/postmaster.pid ]; then
- rm ${pgdata}/postmaster.pid
- fi
- echo "ok"
- return ${ret}
-}
+ procd_set_param user ${pguser}
+ procd_set_param command $PROG
+ procd_append_param command -D "${pgdata}"
+ [ -n "${pgopts}" ] && procd_append_param command -o "${pgopts}"
-restart() {
- echo "restarting postgres..."
- /usr/bin/su ${pguser} -c "${pgctl} stop -D '${pgdata}' -s -m fast -w"
- if [ -f ${pgdata}/postmaster.pid ]; then
- rm ${pgdata}/postmaster.pid
- fi
- /usr/bin/su ${pguser} -c "/usr/bin/postmaster -D '${pgdata}' &" >> ${pglog} 2>&1
- echo "ok"
- return $?
+ procd_set_param respawn retry=60
+ procd_close_instance
}
-reload() {
- echo "reloading postgres..."
- /usr/bin/su ${pguser} -c "${pgctl} reload -D '${pgdata}' -s"
- echo "ok"
+reload_service() {
+ config_load "postgresql"
+ config_get pgdata config PGDATA
+ config_get pguser config PGUSER
+ config_get pgctl config PG_CTL
+ ${pgctl} reload -U ${pguser} -D '${pgdata}' -s
}
status() {
- echo "status postgres..."
- /usr/bin/su ${pguser} -c "${pgctl} status -D '${pgdata}'"
- echo "ok"
+ config_load "postgresql"
+ config_get pgdata config PGDATA
+ config_get pguser config PGUSER
+ config_get pgctl config PG_CTL
+ echo "status postgres..."
+ ${pgctl} status -U ${pguser} -D '${pgdata}'
+ echo "ok"
}
diff --git a/libs/postgresql/patches/001-configure_fixes.patch b/libs/postgresql/patches/001-configure_fixes.patch
new file mode 100644
index 000000000..2edaba6a0
--- /dev/null
+++ b/libs/postgresql/patches/001-configure_fixes.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -25,7 +25,7 @@ recommended. You can remove the check f
+ your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2014, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+-AC_CONFIG_AUX_DIR(config)
++AC_CONFIG_AUX_DIR([config])
+ AC_PREFIX_DEFAULT(/usr/local/pgsql)
+ AC_SUBST(configure_args, [$ac_configure_args])
+
diff --git a/libs/postgresql/patches/200-ranlib.patch b/libs/postgresql/patches/200-ranlib.patch
index 1b68b8378..5fc6d3db9 100644
--- a/libs/postgresql/patches/200-ranlib.patch
+++ b/libs/postgresql/patches/200-ranlib.patch
@@ -1,10 +1,10 @@
--- a/src/port/Makefile
+++ b/src/port/Makefile
-@@ -53,6 +53,7 @@ uninstall:
+@@ -52,6 +52,7 @@ uninstall:
libpgport.a: $(OBJS)
$(AR) $(AROPT) $@ $^
+ $(RANLIB) libpgport.a
# thread.o needs PTHREAD_CFLAGS (but thread_srv.o does not)
- thread.o: thread.c
+ thread.o: CFLAGS+=$(PTHREAD_CFLAGS)
diff --git a/libs/postgresql/patches/800-busybox-default-pager.patch b/libs/postgresql/patches/800-busybox-default-pager.patch
index 3cd253238..1be196991 100644
--- a/libs/postgresql/patches/800-busybox-default-pager.patch
+++ b/libs/postgresql/patches/800-busybox-default-pager.patch
@@ -1,6 +1,6 @@
--- a/src/bin/psql/print.h
+++ b/src/bin/psql/print.h
-@@ -171,10 +171,6 @@ extern void printQuery(const PGresult *r
+@@ -179,10 +179,6 @@ extern void printQuery(const PGresult *r
extern void setDecimalLocale(void);
extern const printTextFormat *get_line_style(const printTableOpt *opt);