aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorSergey V. Lobanov <sergey@lobanov.in>2022-01-03 19:41:37 +0300
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2022-01-06 23:18:23 +0100
commit9a9f26796bdf4bd6ebe5a9aee9dcb2feee54780f (patch)
treee5216dc33561d0c129b5cfea9a938be99fb34099 /libs
parentd35c22951bfabb9b34133471fe1e389909d2007b (diff)
libuhttpd: add compatibility for wolfssl >= 5.0
NTRU support has been removed in wolfssl 5.0 so it is required to mask NTRU specific code if wolfssl >= 5.0 Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
Diffstat (limited to 'libs')
-rw-r--r--libs/libuhttpd/Makefile2
-rw-r--r--libs/libuhttpd/patches/100-wolfssl_5_support.patch21
2 files changed, 22 insertions, 1 deletions
diff --git a/libs/libuhttpd/Makefile b/libs/libuhttpd/Makefile
index 8bdcc0510..d4d48eb49 100644
--- a/libs/libuhttpd/Makefile
+++ b/libs/libuhttpd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libuhttpd
PKG_VERSION:=3.12.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL=https://github.com/zhaojh329/libuhttpd/releases/download/v$(PKG_VERSION)
diff --git a/libs/libuhttpd/patches/100-wolfssl_5_support.patch b/libs/libuhttpd/patches/100-wolfssl_5_support.patch
new file mode 100644
index 000000000..872affdcb
--- /dev/null
+++ b/libs/libuhttpd/patches/100-wolfssl_5_support.patch
@@ -0,0 +1,21 @@
+commit 91b66a6b402b790f3c8cebb0420ef549744ee197
+Author: Sergey V. Lobanov <sergey@lobanov.in>
+Date: Mon Jan 3 19:25:45 2022 +0300
+
+ add compatibility for wolfssl >= 5.0
+
+ NTRU support has been removed in wolfssl 5.0 so it is required to
+ mask NTRU specific code if wolfssl >= 5.0
+
+--- a/src/ssl/openssl.c
++++ b/src/ssl/openssl.c
+@@ -314,7 +314,9 @@ static bool handle_wolfssl_asn_error(voi
+ case ASN_SIG_HASH_E:
+ case ASN_SIG_KEY_E:
+ case ASN_DH_KEY_E:
++#if LIBWOLFSSL_VERSION_HEX < 0x05000000
+ case ASN_NTRU_KEY_E:
++#endif
+ case ASN_CRIT_EXT_E:
+ case ASN_ALT_NAME_E:
+ case ASN_NO_PEM_HEADER: