aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-09-04 16:27:35 -0700
committerGitHub <noreply@github.com>2020-09-04 16:27:35 -0700
commit99d90ee3776c0671166711663d27b6d62be77c12 (patch)
tree0c56de94fa2b6af38136382cd750fdbbd3ec0d47 /libs
parent2edae1a235503d24cb8ece8058839ae759eca440 (diff)
parent6492dce7886972b4d20c4b467070153a7f52bac8 (diff)
Merge pull request #13289 from neheb/inp
libinput: update to 1.16.1
Diffstat (limited to 'libs')
-rw-r--r--libs/libinput/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/libs/libinput/Makefile b/libs/libinput/Makefile
index c5e5e1d2a..62ad85fda 100644
--- a/libs/libinput/Makefile
+++ b/libs/libinput/Makefile
@@ -5,12 +5,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libinput
-PKG_VERSION:=1.15.5
+PKG_VERSION:=1.16.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://www.freedesktop.org/software/libinput/
-PKG_HASH:=a90efc8f423c3094f2f9f372fb92381b2f3aad62e8b5882a8abe333aa8249c97
+PKG_SOURCE_URL:=http://www.freedesktop.org/software/libinput
+PKG_HASH:=7ba7d1aeedd15168bb21d17e9e628aa1c27957963a423a3fea3938a501758539
PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
PKG_LICENSE:=MIT
@@ -50,18 +50,18 @@ MESON_ARGS += \
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/libinput.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libinput.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libinput.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libinput/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/{udev,*.so*} $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/{udev,libinput.so.*} $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/libinput $(1)/usr/bin
endef
$(eval $(call BuildPackage,libinput))