aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-12 02:46:20 -0700
committerGitHub <noreply@github.com>2020-05-12 02:46:20 -0700
commit9697114b39dca0bf7530e2fa263a43df78c42e76 (patch)
tree2d6588f768ee9344ad35de5f5267d76c73d64fc3 /libs
parentc5e30e529e961bf29458924bbb02c43c69ad0d86 (diff)
parentdec17eb36c69435f97c6f5635dc57a76386db818 (diff)
Merge pull request #12152 from jefferyto/aarch64-vfp-neon
treewide: Enable VFP/NEON optimizations for aarch64
Diffstat (limited to 'libs')
-rw-r--r--libs/libpng/Makefile5
-rw-r--r--libs/opus/Makefile4
-rw-r--r--libs/speexdsp/Makefile3
3 files changed, 6 insertions, 6 deletions
diff --git a/libs/libpng/Makefile b/libs/libpng/Makefile
index 5e31a44b8..d4cad1d14 100644
--- a/libs/libpng/Makefile
+++ b/libs/libpng/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpng
PKG_VERSION:=1.6.37
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@SF/libpng
@@ -40,7 +40,8 @@ TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
- $(if $(findstring neon,$(CONFIG_CPU_TYPE)),--enable-hardware-optimizations=yes --enable-arm-neon=yes)
+ $(if $(findstring neon,$(CONFIG_CPU_TYPE))$(findstring aarch64,$(CONFIG_ARCH)), \
+ --enable-hardware-optimizations=yes --enable-arm-neon=yes)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin
diff --git a/libs/opus/Makefile b/libs/opus/Makefile
index 1c106128f..40b13f67e 100644
--- a/libs/opus/Makefile
+++ b/libs/opus/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=opus
PKG_VERSION:=1.3.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://archive.mozilla.org/pub/opus
@@ -47,7 +47,7 @@ ifeq ($(CONFIG_SOFT_FLOAT),y)
--enable-fixed-point
endif
-ifneq ($(findstring neon,$(CONFIG_CPU_TYPE)),)
+ifneq ($(findstring neon,$(CONFIG_CPU_TYPE))$(findstring aarch64,$(CONFIG_ARCH)),)
CONFIGURE_ARGS+= \
--enable-fixed-point
endif
diff --git a/libs/speexdsp/Makefile b/libs/speexdsp/Makefile
index 284a1cab3..14a350c34 100644
--- a/libs/speexdsp/Makefile
+++ b/libs/speexdsp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=speexdsp
PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://downloads.us.xiph.org/releases/speex/
@@ -60,7 +60,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-examples \
- $(if $(CONFIG_aarch64),--disable-neon) \
$(if $(CONFIG_SOFT_FLOAT),--enable-fixed-point --disable-float-api)
$(eval $(call BuildPackage,libspeexdsp))