aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorIan Cooper <iancooper@hotmail.com>2020-05-26 20:27:09 +0100
committerIan Cooper <iancooper@hotmail.com>2020-05-26 20:27:09 +0100
commit918983044fcbe70336abee32c8d48a985452d9b1 (patch)
treeb2b7be8d33a6ccf0bac4c764c899bea7216ad244 /libs
parentf5fdcf3e7eb2671d16d5eabc63882252855ca571 (diff)
avahi: fix reliance on config symbol SSP_SUPPORT
The config symbol SSP_SUPPORT is ambiguous and means different things to different packages: either "toolchain is compiled with ssp support" or "toolchain uses gcc libssp". The use of the symbol should be deprecated and the appropriate symbol used instead. Signed-off-by: Ian Cooper <iancooper@hotmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/avahi/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/libs/avahi/Makefile b/libs/avahi/Makefile
index 3da22bb3b..0b5bec29d 100644
--- a/libs/avahi/Makefile
+++ b/libs/avahi/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=avahi
PKG_VERSION:=0.8
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/lathiat/avahi/releases/download/v$(PKG_VERSION) \
@@ -251,7 +251,7 @@ $(call Package/avahi/Default/description)
endef
TARGET_CFLAGS += $(FPIC) -DGETTEXT_PACKAGE
-TARGET_LDFLAGS += $(if $(CONFIG_SSP_SUPPORT),-lssp_nonshared)
+TARGET_LDFLAGS += $(if $(CONFIG_GCC_LIBSSP),-lssp_nonshared)
CONFIGURE_ARGS += \
--enable-shared \