aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2023-05-06 11:46:49 +0300
committerHannu Nyman <hannu.nyman@iki.fi>2023-05-06 18:19:00 +0300
commit8f8444c12a74139149e6643654c89737f9231bd6 (patch)
treed865b039b1d2f32473e3325a0298221eb8440d6d /libs
parent8c704f2cccc3a6e0796f2a0c1d9747d8255971a8 (diff)
gperf: remove - moved to OpenWrt main repo
Remove gperf that was moved into the main OpenWrt repo. Commit in OpenWrt: 2070a2ca27bdb2b1e4e1587274e192e42f247516 Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Diffstat (limited to 'libs')
-rw-r--r--libs/gperf/Makefile47
-rw-r--r--libs/gperf/patches/100-include_own_first.patch26
2 files changed, 0 insertions, 73 deletions
diff --git a/libs/gperf/Makefile b/libs/gperf/Makefile
deleted file mode 100644
index 5035895c4..000000000
--- a/libs/gperf/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-#
-# Copyright (C) 2006-2017 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gperf
-PKG_VERSION:=3.1
-PKG_RELEASE:=1
-PKG_HASH:=588546b945bba4b70b6a3a616e80b4ab466e3f33024a352fc2198112cdbb3ae2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@GNU/gperf
-PKG_HOST_ONLY=1
-
-PKG_MAINTAINER:=Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
-PKG_LICENSE:=GPL-3.0
-PKG_LICENSE_FILES:=COPYING
-
-include $(INCLUDE_DIR)/host-build.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/gperf
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=GNU gperf
- BUILDONLY:=1
- URL:=http://www.gnu.org/software/gperf
-endef
-
-define Package/gperf/description
- GNU gperf is a perfect hash function generator. For a given list of strings, it
- produces a hash function and hash table, in form of C or C++ code, for looking
- up a value depending on the input string. The hash function is perfect, which
- means that the hash table has no collisions, and the hash table lookup needs a
- single string comparison only.
-endef
-
-define Host/Install
- $(MAKE) -C $(HOST_BUILD_DIR) install
-endef
-
-$(eval $(call HostBuild))
-$(eval $(call BuildPackage,gperf))
diff --git a/libs/gperf/patches/100-include_own_first.patch b/libs/gperf/patches/100-include_own_first.patch
deleted file mode 100644
index 6936f35db..000000000
--- a/libs/gperf/patches/100-include_own_first.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/lib/Makefile.in b/lib/Makefile.in
-index 29bbf92..cf2bf3c 100644
---- a/lib/Makefile.in
-+++ b/lib/Makefile.in
-@@ -61,7 +61,7 @@ SHELL = /bin/sh
- VPATH = $(srcdir)
-
- OBJECTS = getopt.$(OBJEXT) getopt1.$(OBJEXT) getline.$(OBJEXT) hash.$(OBJEXT)
--CPPFLAGS = @CPPFLAGS@ -I$(srcdir)
-+CPPFLAGS = -I$(srcdir) @CPPFLAGS@
-
- TARGETLIB = libgp.a
-
-diff --git a/src/Makefile.in b/src/Makefile.in
-index 6866ffd..bd4df14 100644
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -64,7 +64,7 @@ VPATH = $(srcdir)
- OBJECTS = version.$(OBJEXT) positions.$(OBJEXT) options.$(OBJEXT) keyword.$(OBJEXT) keyword-list.$(OBJEXT) \
- input.$(OBJEXT) bool-array.$(OBJEXT) hash-table.$(OBJEXT) search.$(OBJEXT) output.$(OBJEXT) main.$(OBJEXT)
- LIBS = ../lib/libgp.a @GPERF_LIBM@
--CPPFLAGS = @CPPFLAGS@ -I. -I$(srcdir)/../lib
-+CPPFLAGS = -I. -I$(srcdir)/../lib @CPPFLAGS@
-
- TARGETPROG = gperf$(EXEEXT)
-