aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2020-04-07 16:45:19 +0800
committerJeffery To <jeffery.to@gmail.com>2020-04-08 17:06:35 +0800
commit8b845769486cced87d18c20d29009203b01c697e (patch)
treebf97837399c8cc9a33a5cd1ab835c64026b01e86 /libs
parente3e464ed12e08195758f3329edd42cb2bf690df1 (diff)
libsearpc: Update to "new" version, switch to git download method
Upstream changed the v3.2.0 tag. Previously it referred to haiwen/libsearpc@23f581b39fa4555ede80efe2729f76e6159e8b7a; now it refers to haiwen/libsearpc@d1fd7518a20b25766ff98d6fde6e40c63626ca0d. This changes the packaged version to the "new" v3.2.0 and switches to using the git download method (technically the github_archive method), since the codeload filenames of the previous and current versions are the same but the files have different hashes. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libsearpc/Makefile11
-rw-r--r--libs/libsearpc/patches/001-fix-memory-leak-GH-48.patch19
2 files changed, 7 insertions, 23 deletions
diff --git a/libs/libsearpc/Makefile b/libs/libsearpc/Makefile
index b2eba09a0..2183b8a47 100644
--- a/libs/libsearpc/Makefile
+++ b/libs/libsearpc/Makefile
@@ -9,17 +9,20 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libsearpc
PKG_VERSION:=3.2.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://codeload.github.com/haiwen/libsearpc/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=c479d85e405674c3450eac040abe143af5a9fafe7f1b74926e2a05280ab5420e
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/haiwen/libsearpc.git
+PKG_SOURCE_VERSION:=d1fd7518a20b25766ff98d6fde6e40c63626ca0d
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(call version_abbrev,$(PKG_SOURCE_VERSION))
+PKG_MIRROR_HASH:=ee8b8b50b480afbcb71bd73cd9c2a96cfa72e9dafaf5773574adbf348e49a0d4
PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>, Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE.txt
PKG_FIXUP:=autoreconf
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
diff --git a/libs/libsearpc/patches/001-fix-memory-leak-GH-48.patch b/libs/libsearpc/patches/001-fix-memory-leak-GH-48.patch
deleted file mode 100644
index a0ae81fce..000000000
--- a/libs/libsearpc/patches/001-fix-memory-leak-GH-48.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-From 9b2e2dc65213fb22ed400dc54e4c2279564df62b Mon Sep 17 00:00:00 2001
-From: ly1217 <yu.liu@seafile.com>
-Date: Thu, 31 Oct 2019 00:31:38 -0700
-Subject: [PATCH] Fix memory leak.
-
----
- lib/searpc-named-pipe-transport.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/lib/searpc-named-pipe-transport.c
-+++ b/lib/searpc-named-pipe-transport.c
-@@ -377,6 +377,7 @@ void searpc_free_client_with_pipe_transp
- close(pipe_client->pipe_fd);
- #endif
- g_free (pipe_client);
-+ g_free (data->service);
- g_free (data);
- searpc_client_free (client);
- }