aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-06-18 20:06:03 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-06-18 20:08:26 -0700
commit85b33b9097d8a2f98b6e8a1c3fe214b0663fca93 (patch)
treeae1b120551ded1d7eec1af3262786dc6bd91a31b /libs
parentcdc800874a50ab946078bcf3da859295d3ecebfa (diff)
rxtx: Fix permissions and format
* Don't make the Makefile executable * run dos2unix on the Makefile Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--[-rwxr-xr-x]libs/rxtx/Makefile98
1 files changed, 49 insertions, 49 deletions
diff --git a/libs/rxtx/Makefile b/libs/rxtx/Makefile
index 5a1374f4b..aaafd1836 100755..100644
--- a/libs/rxtx/Makefile
+++ b/libs/rxtx/Makefile
@@ -1,49 +1,49 @@
-#
-# Copyright (C) 2016 Dana H. Myers <k6jq@comcast.net>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=rxtx
-PKG_VERSION:=2.2pre2
-PKG_RELEASE:=1
-PKG_LICENSE:=LGPL-2.1
-PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
-PKG_SOURCE_URL:=http://rxtx.qbang.org/pub/rxtx/
-PKG_MD5SUM:=7eedb18e3f33a427e2b0e9be8ce3f94c
-
-PKG_FIXUP:=patch-libtool
-PKG_CHECK_FORMAT_SECURITY:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/rxtx
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=RX/TX Support for Java serial communications
- URL:=http://rxtx.qbang.org/wiki/index.php/Main_Page
- DEPENDS:=+libpthread
-endef
-
-define Package/rxtx/description
- RX/TX Support for Java serial communications
-endef
-
-CONFIGURE_ARGS += \
- --disable-PRINTER
-
-define Package/rxtx/install
- $(INSTALL_DIR) \
- $(1)/usr/lib/classpath
- $(CP) $(PKG_BUILD_DIR)/$(GNU_TARGET_NAME)-gnu/.libs/*.so \
- $(1)/usr/lib/classpath/
- $(CP) $(PKG_BUILD_DIR)/RXTXcomm.jar \
- $(1)/usr/lib/classpath/
-endef
-
-$(eval $(call BuildPackage,rxtx))
+#
+# Copyright (C) 2016 Dana H. Myers <k6jq@comcast.net>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rxtx
+PKG_VERSION:=2.2pre2
+PKG_RELEASE:=1
+PKG_LICENSE:=LGPL-2.1
+PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://rxtx.qbang.org/pub/rxtx/
+PKG_MD5SUM:=7eedb18e3f33a427e2b0e9be8ce3f94c
+
+PKG_FIXUP:=patch-libtool
+PKG_CHECK_FORMAT_SECURITY:=0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/rxtx
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=RX/TX Support for Java serial communications
+ URL:=http://rxtx.qbang.org/wiki/index.php/Main_Page
+ DEPENDS:=+libpthread
+endef
+
+define Package/rxtx/description
+ RX/TX Support for Java serial communications
+endef
+
+CONFIGURE_ARGS += \
+ --disable-PRINTER
+
+define Package/rxtx/install
+ $(INSTALL_DIR) \
+ $(1)/usr/lib/classpath
+ $(CP) $(PKG_BUILD_DIR)/$(GNU_TARGET_NAME)-gnu/.libs/*.so \
+ $(1)/usr/lib/classpath/
+ $(CP) $(PKG_BUILD_DIR)/RXTXcomm.jar \
+ $(1)/usr/lib/classpath/
+endef
+
+$(eval $(call BuildPackage,rxtx))