aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-07-03 19:33:24 -0700
committerRosen Penev <rosenp@gmail.com>2020-08-31 00:18:25 -0700
commit84475baeda1ce74dc33f24c59097e2f2cf1b7d59 (patch)
treea3c5dc574871508b08a70a9ce2714a385c72a1bd /libs
parentbd89bd24f3e0f701a223abd92846c75913fa9bfb (diff)
lttng-ust: update to 2.12.0
Removed pointless patch. Reworked configure section. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/lttng-ust/Makefile18
-rw-r--r--libs/lttng-ust/patches/001-no_docs_tests.patch11
2 files changed, 8 insertions, 21 deletions
diff --git a/libs/lttng-ust/Makefile b/libs/lttng-ust/Makefile
index 2dd3dffea..90e8d1e95 100644
--- a/libs/lttng-ust/Makefile
+++ b/libs/lttng-ust/Makefile
@@ -8,19 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lttng-ust
-PKG_VERSION:=2.10.3
+PKG_VERSION:=2.12.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)/
-PKG_HASH:=9e8420f90d5f963f7aa32bc6d44adc1e491136f687c69ffb7a3075d33b40852b
+PKG_HASH:=1983edb525f3f27e3494088d8d5389b4c71af66bbfe63c6f1df2ad95aa44a528
PKG_MAINTAINER:=
PKG_LICENSE:=LGPL-2.1 GPL-2.0
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:lttng:ust
-PKG_FIXUP:=autoreconf
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
@@ -35,13 +34,12 @@ define Package/lttng-ust
DEPENDS:= +liburcu +libuuid +librt
endef
-TARGET_CFLAGS += $(FPIC)
-
CONFIGURE_ARGS += \
- --without-pic
-
-CONFIGURE_VARS += \
- ac_cv_prog_BUILD_GEN_TP_EXAMPLES=no
+ --disable-numa \
+ --disable-python-agent \
+ --disable-examples \
+ --disable-man-pages \
+ --with-pic
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
@@ -49,7 +47,7 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust.pc $(1)/usr/lib/pkgconfig/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lttng-ust* $(1)/usr/lib/pkgconfig/
endef
define Package/lttng-ust/install
diff --git a/libs/lttng-ust/patches/001-no_docs_tests.patch b/libs/lttng-ust/patches/001-no_docs_tests.patch
deleted file mode 100644
index 6dee80341..000000000
--- a/libs/lttng-ust/patches/001-no_docs_tests.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -26,8 +26,6 @@ SUBDIRS += python-lttngust \
- liblttng-ust-python-agent
- endif
-
--SUBDIRS += tests doc
--
- #temporarily disabled
- # liblttng-ust-malloc
-