aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorThomas Heil <heil@terminal-consulting.de>2014-07-12 13:35:04 +0200
committerThomas Heil <heil@terminal-consulting.de>2014-07-12 13:35:04 +0200
commit7f705d4b28c2dff889044527600a600a9fae29c2 (patch)
treecf493e0b2933f000d89a8af3147432b0a34778bd /libs
parent0661fbcf90658044d268d7e96423dc2d689f3ba0 (diff)
unixodbc: import from oldpackages, add myself as maintainer, add license
information, update to v2.3.2 Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Diffstat (limited to 'libs')
-rw-r--r--libs/unixodbc/Makefile117
-rw-r--r--libs/unixodbc/files/unixodbc_conf.h22
2 files changed, 139 insertions, 0 deletions
diff --git a/libs/unixodbc/Makefile b/libs/unixodbc/Makefile
new file mode 100644
index 000000000..5c6f4e116
--- /dev/null
+++ b/libs/unixodbc/Makefile
@@ -0,0 +1,117 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=unixodbc
+PKG_VERSION:=2.3.2
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=ftp://ftp.unixodbc.org/pub/unixODBC/
+PKG_SOURCE:=unixODBC-$(PKG_VERSION).tar.gz
+PKG_MD5SUM:=5e4528851eda5d3d4aed249b669bd05b
+PKG_BUILD_DIR:=$(BUILD_DIR)/unixODBC-$(PKG_VERSION)
+PKG_MAINTAINER:=Thomas Heil <heil@terminal-consulting.de>
+PKG_LICENSE:=prog GPL libs LGPL
+
+include $(INCLUDE_DIR)/package.mk
+CONFIGURE_ARGS += \
+ --disable-gui \
+ --with-pic \
+ --enable-drivers
+
+define Package/unixodbc/Default
+ SUBMENU:=database
+ TITLE:=unixODBC
+ URL:=http://www.unixodbc.org/
+endef
+
+define Package/unixodbc
+ $(call Package/unixodbc/Default)
+ TITLE+= (libraries)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libltdl +libpthread
+endef
+
+define Package/unixodbc/description
+ unixODBC is an Open Source ODBC sub-system and an ODBC SDK for Linux,
+ Mac OSX, and UNIX.
+endef
+
+define Package/unixodbc-tools
+ $(call Package/unixodbc/Default)
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE+= Tools
+ DEPENDS:=+unixodbc +libncurses +libreadline
+endef
+
+define Package/unixodbc-tools/description
+ Command Line Tools to help install a driver and work with SQL.
+endef
+
+define Package/pgsqlodbc
+ $(call Package/unixodbc/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Postgresql driver for ODBC
+ DEPENDS:=+unixodbc +libpq
+endef
+
+define Package/pgsqlodbc/description
+ Postgresql driver for ODBC.
+endef
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ $(MAKE_FLAGS) \
+ ARCH="$(ARCH)" \
+ CC="$(TARGET_CC)"
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ DESTDIR="$(PKG_INSTALL_DIR)" \
+ $(MAKE_FLAGS) \
+ ARCH="$(ARCH)" \
+ install -i
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/etc
+ $(CP) $(PKG_INSTALL_DIR)/etc/odbc* $(1)/etc/
+ $(INSTALL_DIR) $(1)/etc/ODBCDataSources
+ $(TARGET_CC) $(TARGET_CFLAGS) -E ./files/unixodbc_conf.h | tr '@' '\#' >$(1)/usr/include/unixodbc_conf.h
+endef
+
+define Package/unixodbc/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libodbc[ci]*so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libodbc.*so* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libnn*so* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/etc
+ $(CP) $(PKG_INSTALL_DIR)/etc/odbc* $(1)/etc/
+endef
+
+define Package/unixodbc-tools/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
+define Package/pgsqlodbc/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libodbcpsql*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,unixodbc))
+$(eval $(call BuildPackage,unixodbc-tools))
+$(eval $(call BuildPackage,pgsqlodbc))
diff --git a/libs/unixodbc/files/unixodbc_conf.h b/libs/unixodbc/files/unixodbc_conf.h
new file mode 100644
index 000000000..f149d02b1
--- /dev/null
+++ b/libs/unixodbc/files/unixodbc_conf.h
@@ -0,0 +1,22 @@
+@ifndef HAVE_UNISTD_H
+ @define HAVE_UNISTD_H
+@endif
+@ifndef HAVE_PWD_H
+ @define HAVE_PWD_H
+@endif
+@ifndef HAVE_SYS_TYPES_H
+ @define HAVE_SYS_TYPES_H
+@endif
+@ifndef HAVE_LONG_LONG
+ @define HAVE_LONG_LONG
+@endif
+@ifndef ODBCINT64
+ @define ODBCINT64 long
+@endif
+@ifndef UODBCINT64
+ @define UODBCINT64 unsigned long
+@endif
+@ifndef SIZEOF_LONG_INT
+ @define SIZEOF_LONG_INT __SIZEOF_LONG__
+@endif
+ \ No newline at end of file