aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorChristian Marangi <ansuelsmth@gmail.com>2024-04-11 17:07:36 +0200
committerChristian Marangi <ansuelsmth@gmail.com>2024-05-05 17:25:12 +0200
commit7cdf7b9c1ad1c86e86c0ae11a442a43dff5873ce (patch)
treec063cbe66a978bffaa9df0fcb55dd832b352721a /libs
parent7410fe81889968b704b65115101ff1ee81b074cb (diff)
libs: glib2: fix provided pkg-config and always use host tools
For the InstallDev target, the pkg-config should point to the glib2 host tools for glib_compile_resources, gdbus_codegen, glib_genmarshal and glib_mkenums instead of pointing to the targets ones as they are unusable by the host machine (due to crosscompiling) Fix the pkg-config to reference the host tools by replaying the entry and use the prefix_hostpkg variable provided by our pkg-config. Link: https://github.com/openwrt/packages/pull/23881 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/glib2/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index ef36e162c..3c5e707c0 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -100,6 +100,12 @@ define Build/InstallDev
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
$(1)/usr/lib/pkgconfig
+ $(foreach BIN,glib_genmarshal glib_mkenums,
+ $(SED) 's/^$(BIN)=$$$${bindir}\/\(.*\)/$(BIN)=$$$${prefix_hostpkg}\/bin\/\1/' $(1)/usr/lib/pkgconfig/glib-2.0.pc
+ )
+ $(foreach BIN,glib_compile_resources gdbus_codegen,
+ $(SED) 's/^$(BIN)=$$$${bindir}\/\(.*\)/$(BIN)=$$$${prefix_hostpkg}\/bin\/\1/' $(1)/usr/lib/pkgconfig/gio-2.0.pc
+ )
$(INSTALL_DIR) $(2)/share/aclocal/
$(INSTALL_DATA) \