aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-10 10:52:11 -0300
committerEneas U de Queiroz <cote2004-github@yahoo.com>2019-05-24 14:55:47 -0300
commit7cb6405afe100a01c7b9ec49a9d6b3a37e732212 (patch)
tree03016df636d88b35708022cd4509900a6a8b8c9a /libs
parent5b73b31f9b0e7863121e52ee21d9dec1cd45d0b0 (diff)
oniguruma: add new package
oniguruma is a regular expression library for different character encodings. It is a dependency of current version of libevhtp, and is currently only producing a static library, not generating an installable package. Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/oniguruma/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/libs/oniguruma/Makefile b/libs/oniguruma/Makefile
new file mode 100644
index 000000000..33f0e598f
--- /dev/null
+++ b/libs/oniguruma/Makefile
@@ -0,0 +1,54 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=oniguruma
+PKG_VERSION:=6.9.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=onig-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/kkos/oniguruma/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=3b568a9050839e7828b2f2d5bc9cd3650979b6b54a080f54c515320dddda06b0
+
+PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com.br>
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:oniguruma_project:oniguruma
+
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/oniguruma
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Regular expression library for different character encodings
+ URL:=https://github.com/kkos/oniguruma
+ DEPENDS:=
+ ABI_VERSION:=5
+endef
+
+define Package/oniguruma/description
+ Oniguruma is a modern and flexible regular expressions library.
+ It encompasses features from different regular expression implementations that
+ traditionally exist in different languages.
+
+ Character encoding can be specified per regular expression object.
+endef
+
+define Package/oniguruma/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libonig.so.$(ABI_VERSION) $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/{include,lib}
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+ $(SED) 's,/usr,${STAGING_DIR}/usr,g' $(1)/usr/lib/pkgconfig/oniguruma.pc
+endef
+
+$(eval $(call BuildPackage,oniguruma))