aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorsbyx <steven@midlink.org>2014-09-15 17:43:02 +0200
committersbyx <steven@midlink.org>2014-09-15 17:43:02 +0200
commit7208a95647577303226b8f6ff665f7482c88a4b2 (patch)
tree04c978f4ffc19642e27afcdb33ef5f03e6ff2d3e /libs
parentaa98fabf5545142fa4c1e5f21cadb4f5fb5c0952 (diff)
parent5948b0a632edca99c01f8626274ab380fa3a452b (diff)
Merge pull request #308 from mwarning/master
libs/libsodium: add LIBSODIUM_MINIMAL
Diffstat (limited to 'libs')
-rw-r--r--libs/libsodium/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/libs/libsodium/Makefile b/libs/libsodium/Makefile
index 84f7d414f..77230a621 100644
--- a/libs/libsodium/Makefile
+++ b/libs/libsodium/Makefile
@@ -43,7 +43,17 @@ define Package/libsodium/description
And despite the emphasis on higher security, primitives are faster across-the-board than most implementations of the NIST standards.
endef
-CONFIGURE_ARGS += --disable-ssp
+define Package/libsodium/config
+menu "Configuration"
+ config LIBSODIUM_MINIMAL
+ bool "Create a smaller library"
+ default n
+endmenu
+endef
+
+CONFIGURE_ARGS+= \
+ --disable-ssp \
+ $(if $(CONFIG_LIBSODIUM_MINIMAL),--enable-minimal=yes,--enable-minimal=no)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/sodium