aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2020-04-20 20:05:07 +0300
committerGitHub <noreply@github.com>2020-04-20 20:05:07 +0300
commit6c2235253fc8057421c7c0b58e91c5eff07b407e (patch)
tree45ae98f0d1d8279f83683d4b735f00b6f7dd67b3 /libs
parente40f92c90dbed675d2f1555f65e3d25d9a9aad5a (diff)
parent89ae10ed715ee8ccbbf38c1e723e09a77ad8efff (diff)
Merge pull request #11872 from jefferyto/python3-makefile-cleanup
python3: Makefile cleanup
Diffstat (limited to 'libs')
-rw-r--r--libs/libgpiod/Makefile1
-rw-r--r--libs/libsearpc/Makefile16
-rw-r--r--libs/libsearpc/patches/001-no-python-compile.patch8
-rw-r--r--libs/newt/Makefile6
4 files changed, 17 insertions, 14 deletions
diff --git a/libs/libgpiod/Makefile b/libs/libgpiod/Makefile
index 86604b2de..11bf13ae8 100644
--- a/libs/libgpiod/Makefile
+++ b/libs/libgpiod/Makefile
@@ -22,6 +22,7 @@ PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+PYTHON3_PKG_BUILD:=0
include $(INCLUDE_DIR)/package.mk
include ../../lang/python/python3-package.mk
diff --git a/libs/libsearpc/Makefile b/libs/libsearpc/Makefile
index 2183b8a47..e084e4eb1 100644
--- a/libs/libsearpc/Makefile
+++ b/libs/libsearpc/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libsearpc
PKG_VERSION:=3.2.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/haiwen/libsearpc.git
@@ -25,6 +25,7 @@ PKG_FIXUP:=autoreconf
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PYTHON3_PKG_BUILD:=0
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -50,19 +51,21 @@ define Package/python3-searpc
SUBMENU:=Python
TITLE:=Python bindings for Searpc
DEPENDS:=+libsearpc +python3-light +python3-logging
- VARIANT:=python3
endef
define Package/python3-searpc/description
$(call Package/libsearpc/description)
- This package contains the Python bindings for Searpc.
+ This package contains Python bindings for Searpc.
endef
CONFIGURE_ARGS += \
--disable-compile-demo \
--disable-server-pkg
+CONFIGURE_VARS += \
+ PYTHON="$(HOST_PYTHON3_BIN)"
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/{bin,include}
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
@@ -77,13 +80,6 @@ define Package/libsearpc/install
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsearpc.so* $(1)/usr/lib/
endef
-define Py3Build/Compile
- rm -rf $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/pysearpc
- $(INSTALL_DIR) $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/pysearpc
- $(INSTALL_DATA) $(PKG_BUILD_DIR)/pysearpc/*.py $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/pysearpc/
- rm -f $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/pysearpc/{pygencode,test_pysearpc}.py
-endef
-
Py3Package/python3-searpc/install:=:
$(eval $(call BuildPackage,libsearpc))
diff --git a/libs/libsearpc/patches/001-no-python-compile.patch b/libs/libsearpc/patches/001-no-python-compile.patch
new file mode 100644
index 000000000..fc9120b0f
--- /dev/null
+++ b/libs/libsearpc/patches/001-no-python-compile.patch
@@ -0,0 +1,8 @@
+--- a/pysearpc/Makefile.am
++++ b/pysearpc/Makefile.am
+@@ -1,4 +1,4 @@
+
+ pysearpcdir=${pyexecdir}/pysearpc
+
+-pysearpc_PYTHON = __init__.py client.py common.py errors.py named_pipe.py server.py transport.py utils.py
++pysearpc_DATA = __init__.py client.py common.py errors.py named_pipe.py server.py transport.py utils.py
diff --git a/libs/newt/Makefile b/libs/newt/Makefile
index 10abe55f4..dd4ddcb2c 100644
--- a/libs/newt/Makefile
+++ b/libs/newt/Makefile
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=newt
PKG_VERSION:=0.52.21
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://releases.pagure.org/newt
@@ -24,6 +24,7 @@ PKG_CPE_ID:=cpe:/a:fedorahosted:newt
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PYTHON3_PKG_BUILD:=0
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
@@ -73,7 +74,6 @@ $(call Package/newt/Default)
SUBMENU:=Python
TITLE+= module for Python
DEPENDS:=+libnewt +python3-light
- VARIANT:=python3
endef
define Package/python3-newt/description
@@ -93,8 +93,6 @@ CONFIGURE_VARS += $(if $(CONFIG_BUILD_NLS),ac_cv_lib_c_gettext=no)
MAKE_VARS+= PYTHON_CONFIG_PATH="$(STAGING_DIR)/host/bin"
-Build/Compile=$(call Build/Compile/Default,)
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/newt.h $(1)/usr/include/