aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorEduardo Abinader <eduardoabinader@gmail.com>2018-11-10 00:12:42 +0100
committerEduardo Abinader <eduardoabinader@gmail.com>2018-11-12 13:02:21 +0100
commit62c2fd467962b25bbeb97bb39e98df6dad382737 (patch)
tree17716aff19778547ecedbdfaa8f5352dca8b27dd /libs
parent9eba4f5801a77c131fac01d65c5d719544b2f9d1 (diff)
libopusenc: required by opus-tools 0.2
new dep on opus-tools a638dfa37bd857e14b088e0ccade701dc6aafc79 Signed-off-by: Eduardo Abinader <eduardoabinader@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/libopusenc/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/libs/libopusenc/Makefile b/libs/libopusenc/Makefile
new file mode 100644
index 000000000..3f0dba57d
--- /dev/null
+++ b/libs/libopusenc/Makefile
@@ -0,0 +1,51 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libopusenc
+PKG_VERSION:=0.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://archive.mozilla.org/pub/opus
+PKG_HASH:=8298db61a8d3d63e41c1a80705baa8ce9ff3f50452ea7ec1c19a564fe106cbb9
+
+PKG_MAINTAINER:=Eduardo Abinader <eduardoabinader@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=COPYING
+
+PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libopusenc
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libopus
+ TITLE:=OPUS Audio stream files
+ URL:=https://opus-codec.org
+endef
+
+define Package/libopusenc/descriptiion
+ Libopusenc provides a high-level API for creating .opus files and streams.
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libopusenc.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libopusenc/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libopusenc))