aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-15 22:58:42 +0800
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-15 19:36:37 +0200
commit60077281fe5ec6db351247b9186278ad2e78014a (patch)
tree57932d1dd25fb4226bd22fa2d3d95648b08e2d85 /libs
parentf6c43e7c5ad86685f6e5c892b0b412fbd8831200 (diff)
libunistring: remove package
It's merged into core now [1], so remove it here. 1. https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=d3c3b79c1e46c49cfa5de9df6a740d5fcda46471 Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'libs')
-rw-r--r--libs/libunistring/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/libs/libunistring/Makefile b/libs/libunistring/Makefile
deleted file mode 100644
index 595b5308f..000000000
--- a/libs/libunistring/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-#
-# Copyright (C) 2006-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libunistring
-PKG_VERSION:=1.1
-PKG_RELEASE:=1
-PKG_HASH:=827c1eb9cb6e7c738b171745dac0888aa58c5924df2e59239318383de0729b98
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNU/libunistring
-PKG_BUILD_PARALLEL:=1
-PKG_INSTALL:=1
-
-PKG_MAINTAINER:=Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
-PKG_LICENSE:=GPL-3.0
-PKG_LICENSE_FILES:=COPYING
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libunistring
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=libunistring
- URL:=http://www.gnu.org/software/libunistring/
-endef
-
-define Package/libunistring/description
- This library provides functions for manipulating Unicode strings and for manipulating C strings according to the Unicode standard.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-CONFIGURE_ARGS += \
- --enable-shared \
- --enable-static \
- --without-libiconv-prefix \
- --without-libpth-prefix
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
- $(INSTALL_DIR) $(1)/usr/include/unistring
- $(CP) $(PKG_INSTALL_DIR)/usr/include/unistring/*.h $(1)/usr/include/unistring/
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunistring.{a,so*} $(1)/usr/lib/
-endef
-
-define Package/libunistring/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libunistring.so.* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libunistring))