aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorPeter Wagner <tripolar@gmx.at>2016-09-19 21:45:24 +0200
committerPeter Wagner <tripolar@gmx.at>2016-09-19 21:45:24 +0200
commit5dfd322a3a12bd71e47d68e6dff450907bdc6950 (patch)
tree4d2a34660ac24de7aee18c00c70894137e926650 /libs
parent64c6b8b7354dacbd3130f2a60d02adafd3ff6ca4 (diff)
glib2: update to 2.49.7
Signed-off-by: Peter Wagner <tripolar@gmx.at>
Diffstat (limited to 'libs')
-rw-r--r--libs/glib2/Makefile12
-rw-r--r--libs/glib2/patches/001-automake-compat.patch2
-rw-r--r--libs/glib2/patches/002-gdate-Suppress-string-format-literal-warning.patch7
-rw-r--r--libs/glib2/patches/003-gdate-Move-warning-pragma-outside-of-function.patch47
4 files changed, 9 insertions, 59 deletions
diff --git a/libs/glib2/Makefile b/libs/glib2/Makefile
index 583828b93..013e23b16 100644
--- a/libs/glib2/Makefile
+++ b/libs/glib2/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=glib2
-PKG_VERSION:=2.46.2
+PKG_VERSION:=2.49.7
PKG_RELEASE:=1
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
-PKG_SOURCE_URL:=@GNOME/glib/2.46
-PKG_MD5SUM:=7f815d6e46df68e070cb421ed7f1139e
+PKG_SOURCE_URL:=@GNOME/glib/2.49
+PKG_MD5SUM:=397ead3fcf325cb921d54e2c9e7dfd7a
PKG_BUILD_PARALLEL:=1
HOST_BUILD_PARALLEL:=1
@@ -46,7 +46,8 @@ endef
HOST_CONFIGURE_ARGS += \
--disable-selinux \
- --with-libiconv=gnu
+ --with-libiconv=gnu \
+ --with-pcre=internal
CONFIGURE_ARGS += \
--enable-shared \
@@ -54,7 +55,8 @@ CONFIGURE_ARGS += \
--enable-debug=no \
--disable-selinux \
--disable-fam \
- --with-libiconv=gnu
+ --with-libiconv=gnu \
+ --with-pcre=internal
CONFIGURE_VARS += \
glib_cv_stack_grows=no \
diff --git a/libs/glib2/patches/001-automake-compat.patch b/libs/glib2/patches/001-automake-compat.patch
index 602d3f15c..05c28ca15 100644
--- a/libs/glib2/patches/001-automake-compat.patch
+++ b/libs/glib2/patches/001-automake-compat.patch
@@ -1,6 +1,6 @@
--- a/gtk-doc.make
+++ b/gtk-doc.make
-@@ -271,7 +271,7 @@ uninstall-local:
+@@ -282,7 +282,7 @@ uninstall-local:
#
# Require gtk-doc when making dist
#
diff --git a/libs/glib2/patches/002-gdate-Suppress-string-format-literal-warning.patch b/libs/glib2/patches/002-gdate-Suppress-string-format-literal-warning.patch
index a092882ab..01769cb96 100644
--- a/libs/glib2/patches/002-gdate-Suppress-string-format-literal-warning.patch
+++ b/libs/glib2/patches/002-gdate-Suppress-string-format-literal-warning.patch
@@ -9,11 +9,9 @@ https://bugzilla.gnome.org/761550
glib/gdate.c | 3 +++
1 file changed, 3 insertions(+)
-diff --git a/glib/gdate.c b/glib/gdate.c
-index 4aece02..cdc735c 100644
--- a/glib/gdate.c
+++ b/glib/gdate.c
-@@ -2494,7 +2494,10 @@ g_date_strftime (gchar *s,
+@@ -2497,7 +2497,10 @@ g_date_strftime (gchar *s,
* recognize whether strftime actually failed or just returned "".
*/
tmpbuf[0] = '\1';
@@ -24,6 +22,3 @@ index 4aece02..cdc735c 100644
if (tmplen == 0 && tmpbuf[0] != '\0')
{
---
-cgit v0.12
-
diff --git a/libs/glib2/patches/003-gdate-Move-warning-pragma-outside-of-function.patch b/libs/glib2/patches/003-gdate-Move-warning-pragma-outside-of-function.patch
deleted file mode 100644
index c5577b180..000000000
--- a/libs/glib2/patches/003-gdate-Move-warning-pragma-outside-of-function.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 8cdbc7fb2c8c876902e457abe46ee18a0b134486 Mon Sep 17 00:00:00 2001
-From: coypu <coypu@sdf.org>
-Date: Wed, 2 Mar 2016 19:38:48 +0200
-Subject: gdate: Move warning pragma outside of function
-
-Commit 0817af40e8c74c721c30f6ef482b1f53d12044c7 breaks the build on
-older versions of GCC, which don't allow pragma inside functions.
-
-https://bugzilla.gnome.org/761550
----
- glib/gdate.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/glib/gdate.c b/glib/gdate.c
-index cdc735c..92c34d2 100644
---- a/glib/gdate.c
-+++ b/glib/gdate.c
-@@ -2439,6 +2439,9 @@ win32_strftime_helper (const GDate *d,
- *
- * Returns: number of characters written to the buffer, or 0 the buffer was too small
- */
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Wformat-nonliteral"
-+
- gsize
- g_date_strftime (gchar *s,
- gsize slen,
-@@ -2494,10 +2497,7 @@ g_date_strftime (gchar *s,
- * recognize whether strftime actually failed or just returned "".
- */
- tmpbuf[0] = '\1';
-- #pragma GCC diagnostic push
-- #pragma GCC diagnostic ignored "-Wformat-nonliteral"
- tmplen = strftime (tmpbuf, tmpbufsize, locale_format, &tm);
-- #pragma GCC diagnostic pop
-
- if (tmplen == 0 && tmpbuf[0] != '\0')
- {
-@@ -2552,3 +2552,5 @@ g_date_strftime (gchar *s,
- return retval;
- #endif
- }
-+
-+#pragma GCC diagnostic pop
---
-cgit v0.12
-