aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2014-08-20 14:52:47 +0200
committerNicolas Thill <nico@openwrt.org>2014-08-20 21:06:49 +0200
commit5b87eb7290177be15dea34d9a8d2fa3d664d573c (patch)
tree9f68985be66d89b80a0c42b32a21d73551692049 /libs
parentf0bdbbe8f775ff601599684c6e916d6c4f051646 (diff)
freetype: import from old packages feed
- update to latest version (v2.5.3) - add license info - add myself as maintainer Signed-off-by: Nicolas Thill <nico@openwrt.org>
Diffstat (limited to 'libs')
-rw-r--r--libs/freetype/Makefile78
1 files changed, 78 insertions, 0 deletions
diff --git a/libs/freetype/Makefile b/libs/freetype/Makefile
new file mode 100644
index 000000000..f6fd7a4bc
--- /dev/null
+++ b/libs/freetype/Makefile
@@ -0,0 +1,78 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=freetype
+PKG_VERSION:=2.5.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/freetype
+PKG_MD5SUM:=d6b60f06bfc046e43ab2a6cbfd171d65
+
+PKG_LICENSE:=FTL GPL-2.0 MIT ZLIB
+PKG_LICENSE_FILES:=docs/LICENSE.TXT docs/FTL.TXT docs/GPLv2.TXT src/bdf/README src/pcf/README src/gzip/zlib.h
+PKG_MAINTAINER:=Nicolas Thill <nico@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_LIBTOOL_PATHS:=builds/unix
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libfreetype
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A free, high-quality and portable font engine
+ URL:=http://www.freetype.org/
+ DEPENDS:=+zlib +libbz2
+endef
+
+define Package/libfreetype/description
+ The FreeType project is a team of volunteers who develop free,
+ portable and high-quality software solutions for digital typography.
+ They specifically target embedded systems and focus on bringing small,
+ efficient and ubiquitous products.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --with-bzip2=yes \
+ --with-zlib=yes \
+ --with-png=no \
+
+define Build/Compile
+ $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" all install
+endef
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(2)/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/freetype-config $(2)/bin/
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/freetype2 $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.{a,so*} $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/freetype2.pc $(1)/usr/lib/pkgconfig/
+
+ $(SED) \
+ 's,^\(prefix\|exec_prefix\)=.*,\1="$(STAGING_DIR)/usr",g' \
+ $(2)/bin/freetype-config
+endef
+
+
+define Package/libfreetype/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libfreetype.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call HostBuild))
+$(eval $(call BuildPackage,libfreetype))