aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorclaymore <carlosmf.pt@gmail.com>2015-07-30 04:02:18 +0100
committerclaymore <carlosmf.pt@gmail.com>2015-07-30 04:04:14 +0100
commit5586dce88d9c3a821a15f98fd63be12e1b7e0c01 (patch)
tree0de025d61536d87be602f4e656e4b8ba47f3e4ed /libs
parent76e84e8be9a86c28ee1d8b8dc785e60df6b1d49a (diff)
Boost Makefile Update - Release 6
This update solves two issues: 1) Incompatibility with the combination of using Target mpc85xx and uclibc at the same time[1]. - For now, Boost is disabled when the respective combination is detected. 2) The selection of Boost.Locale was not activating the build with full language support. [1] - https://github.com/openwrt/packages/issues/1621 Signed-off-by: Carlos Ferreira <carlosmf.pt@gmail.com>
Diffstat (limited to 'libs')
-rw-r--r--libs/boost/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/libs/boost/Makefile b/libs/boost/Makefile
index ef0f31f02..c2d273e7e 100644
--- a/libs/boost/Makefile
+++ b/libs/boost/Makefile
@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/target.mk
PKG_NAME:=boost
PKG_VERSION:=1_58_0
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/boost
@@ -34,13 +34,13 @@ PKG_USE_MIPS16:=0
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
-
+# For now, the combination TARGET_mpc85xx&&USE_UCLIBC disables boost due to incompatibility
define Package/boost/Default
SECTION:=libs
CATEGORY:=Libraries
TITLE:=Boost C++ source library
URL:=http://www.boost.org
- DEPENDS:=+libstdcpp +libpthread +librt
+ DEPENDS:=@(!(TARGET_mpc85xx&&USE_UCLIBC)) +libstdcpp +libpthread +librt
endef
define Package/boost/description/Default
@@ -72,10 +72,11 @@ define Package/boost/install
true
endef
+# For now, the combination TARGET_mpc85xx&&USE_UCLIBC disables boost due to incompatibility
define Package/boost
$(call Package/boost/Default)
TITLE+= packages
- DEPENDS:=+ALL:boost-libs +ALL:boost-test
+ DEPENDS:=@(!(TARGET_mpc85xx&&USE_UCLIBC)) +ALL:boost-libs +ALL:boost-test
endef
define Package/boost/config
@@ -107,7 +108,7 @@ PKG_CONFIG_DEPENDS:= CONFIG_PACKAGE_boost-test
define Package/boost-test
$(call Package/boost/Default)
TITLE+= (test)
- HIDDEN:=1
+ HIDDEN:=1
endef
define Build/Configure
@@ -148,7 +149,7 @@ $(eval $(call DefineBoostLibrary,filesystem,system,))
$(eval $(call DefineBoostLibrary,graph,regex,))
#$(eval $(call DefineBoostLibrary,graph_parallel,,))
$(eval $(call DefineBoostLibrary,iostreams,,+zlib))
-$(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS)))
+$(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS) +@BUILD_NLS))
$(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex,))
$(eval $(call DefineBoostLibrary,math,,))
#$(eval $(call DefineBoostLibrary,mpi,,))