aboutsummaryrefslogtreecommitdiff
path: root/libs
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2016-09-24 14:22:51 -0400
committerGitHub <noreply@github.com>2016-09-24 14:22:51 -0400
commit4da62bfbcfe30731a1b2621f316ad25980a09652 (patch)
tree83f7a83d8b7bbb1a24f869e29600973db4036c3a /libs
parent82a482e92a7be63371e0e4b233c8f33723e4118b (diff)
parent71160d214a86d52325a9118cb022e4d073102a8e (diff)
Merge pull request #3210 from dangowrt/fix-x264-build
libx264: Fix x264 build (asm)
Diffstat (limited to 'libs')
-rw-r--r--libs/libx264/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/libs/libx264/Makefile b/libs/libx264/Makefile
index 4dc9fec36..808a02ce3 100644
--- a/libs/libx264/Makefile
+++ b/libs/libx264/Makefile
@@ -38,20 +38,22 @@ else
endif
endif
+ifneq ($(CONFIG_SOFT_FLOAT),)
+CONFIGURE_VARS+= AS=
+MAKE_FLAGS+= AS=
+CONFIGURE_ARGS += --disable-asm
+endif
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-pic \
--disable-cli
-ifeq ($(CONFIG_SOFT_FLOAT),y)
-CONFIGURE_ARGS += --disable-asm
-endif
-
define Package/libx264
SECTION:=libs
CATEGORY:=Libraries
TITLE:=H264/AVC free codec library.
- DEPENDS:=@BUILD_PATENTED
+ DEPENDS:=@BUILD_PATENTED @!powerpc||BROKEN
URL:=http://www.videolan.org/developers/x264.html
endef